Upgraded to OH4.0, TR064 binding not working properly any more

Hi folks, I upgraded more or less successfully from OH3.3 to OH4.0. I have a whole bunch of Python rules, Homematic , Modbus, MQTT, Squeezebox, … I had some units of measurement to be fixed, and some JS transformations. Everything seems to work now, except for the TR064 binding.
I have a FritzBox and can get last calls and number of voice messages recorded.
Things file:

Bridge avmfritz:fritzbox:1 "FRITZ!Box" [ipAddress="", user="x", password="y"]
Bridge tr064:fritzbox:1 "FRITZ!Box" [host="", user="x", password="jy", tamIndices="1", phonebookInterval="86400"]

Items files:

Switch  fboxAB0Switch   "Anrufbeantworter konfiguriert"       {channel="tr064:fritzbox:1:tamEnable_1"}
Number  fboxAB0NewMsg   "Neue Nachrichten [%s]"               {channel="tr064:fritzbox:1:tamNewMessages_1"}
String telefonStatus "Status [%s]"  ["Status"] { channel="avmfritz:fritzbox:1:call_state" }

For the item fboxAB0NewMsg, I always get the error messages:

2023-07-27 21:23:27.729 [INFO ] [064.internal.soap.SOAPValueConverter] - Postprocessor processTamListURL failed: Failed to get TAM list from URL

2023-07-27 21:23:27.733 [WARN ] [ng.tr064.internal.soap.SOAPConnector] - Failed to get Tr064ChannelConfig{channelType=tamNewMessages, getAction=GetMessageList, dataType='string, parameter='1'}: failed to transform 'NewURL'

The other two items are working properly.
Does anyone understand what could be happening? This was working before I moved to OH4.0.

Edit: BTW: The TR064 Thing is ONLINE, and the LAN subdevice also, and the LAN subdevice also gives reasonabe values.

1 Like

I get the same error messages since I have updated to OH4.0.

Do you only get the error messages or are your items also not working?

1 Like

My new messages item is also not working, but activating and deactivating the answering machine works.

I do have the the same error and just checking the trace information in the openhab log:

Is it maybe the “& amp;” which is disturbing the transformation routine?

What is being transformed here? Is “NewURL” something that is given from the FritzBox server?

@J-N-K : Do you know about this problem ?

I have tried to create a pull-request, but it was not accepted because of “i am not an contributor”…no idea what this …

So somebody else should do something, that this official binding gets back to work in OH 4

Can you send me the link to your rejected PR via PM please…

Not sure this update fix your issue as well?

No sorry, still the same error with you snapshot running…
I too have just one fritzbox…this error occurs not only with multiple fritzboxes i think…

This is a different issue. I’ll check if it happens for me.

It’s a bug. Please try to set the timeout to “5000” as a workaround (at one place in code the timeout is used as milli-seconds instead of seconds). Also fixed by [tr064] Fix clearing of auth (results) by J-N-K · Pull Request #15415 · openhab/openhab-addons · GitHub

1 Like

Thank you - with new snapshot from last night, it works again!

1 Like

Setting the timeout to “5000” worked for me on OH 4.0.1. - no more error messages.