UPnP control Denon AVR-X1700H


I have a Denon AVR-X1700H and as media server I use Emby. My goal is to control the AVR with OpenHAB3 (currently running 3.2) to stream a predefined playlist.
For now I only installed the UPnP control and it could already find the Emby Server. However the AVR was not found so I tried to add it manually. To find out the udn I went into Windows explorer → Network → and the AVR was found there → Properties shows a uuid. Am I right that this uuid is the udn?
Anyway I used this uuid to manually connect in openHAB but I get this error message:

No connection Id’s set for UPnP device with UDN

Any advice would be very appreciated.

If your Denon receiver could be driven by UPnP, I assume that the UPnP binding would have discovered it. So the most probable hypothesis is that is not possible, not supported by the receiver.

1 Like

Makes sense, but I mean I can use Emby to stream data to the AVR without any issue. Also I can do it using the HEOS APP. It recognizes both the AVR and Emby as the streaming server. So I thought it must be upnp then.
Anyway I tried with an android app and - actually it gets detected as upnp device but not as media renderer. So you are right its probably not controllable using the upnp control binding. Maybe it’s possible with the HEOS binding. But I don’t really understand how to get the playlist from Emby.
Has anyone experience with HEOS binding and an external media server like Emby or Plex?

I have now installed HEOS Binding and asked in the support thread on how to add something to the queue. Heos (Denon) support - #400 by April_Wexler

I think it is supported by the device: manual
I have similiar issues with my Marantz SR6015 which has also support: manual
AFAIK UPnP is the underlaying technology of DNLA. I also found some online shops which sell these receivers with explicit UPnP Support, but thats not an official manufacturer information.

In fact my SR6015 plays music smoothly from bubbleupnp on my Android Phone. Also the Intel UPnP Tools as linked by the UPnP Control Binding detect my device as renderer:

Nowadays many manufacturer use afaik UPnP/DLNA with additions for their own purposes. AFAIK Sonos also an enhanced UPnP Protocol for their speakers. Also my router, tv and printer use it.
I assume, that there could be a couse of this problem. Probably the discovery of upnp-near bindings affects the discovery of “native” upnpcontrol things.

I will keep this thead updated if I will find the time to turn on debug logging of upnpcontrol and LG Web OS binding (which is one of my supects ;-)).