USB-Devices (Z-Wave, RFXCOM) don't work with Linux


i just started to play around with Openhab. First i tested on my Windows PC and a RFXtrx433 and a ZME_UZB1 Z-Wave USB-Stick. Both worked great.

Now i want switch to a “productive” environment, which is a Solidrun CuBox i4Pro. As distro i used this one:

I copied all files from my local Openhab folder to the Linux box, plugged the two devices in the box, changed the ports and started. Everything seemes to work. But the two devices. The bindings aren’t loaded or they don’t connect correctly to the devices, i don’t know. I just don’t get any data…

I think they are mounted correctly:

root@cubox-i:~# lsusb
Bus 001 Device 006: ID 0658:0200 Sigma Designs, Inc.
Bus 002 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

[ 3.593973] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
[ 3.578885] usb 2-1: FTDI USB Serial Device converter now attached to ttyUSB

root@cubox-i:~# ls -alg /dev/ttyUSB0
crw-rw—T 1 dialout 188, 0 Aug 21 10:45 /dev/ttyUSB0

root@cubox-i:~# ls -alg /dev/ttyACM0
crw-rw—T 1 dialout 166, 0 Aug 21 10:45 /dev/ttyACM0

Anything i can try?

did you (where “openhab” is user you are running as)

sudo usermod openhab -a -G dialout

My Pi 2 system worked without this with a z-stick 2e, but when I plugged in the Gen5 had to do add user to the dialout group.

I’m currently testing with root… Therefore it shouldn’t be a permission issue, right?

Fixed the issue: I switched to the Ubuntu image.

There are some notes on configuring OpenHAB for serial devices on Linux in the Wiki.

Regardless to being root, you may still find that you need to add the root user to the dialout group.

Another thing is related to the devices which the serial library considers as default and will check to see if there is anything connected. I don’t remember the list off the top of my head, but the /ttyACM0 device name may not be looked at. If this is the case, you need to add a parameter to the OpenHAB start command to specify other serial ports (documented in the Wiki).

1 Like