USB300 DB Enocean can not found in opehab(Windows)

Could anyone help me?

Currently, I am using openhab on Windows. And I want to connect openhab with enocean devices via usb300 db
But when I plugged the usb into the computer and installed the enocean binding, I searched the inbox but didn’t see the connection to the usb. I didn’t know how to connect the 300 db usb to openhab. I do not know if my computer has any error or missing files? Can everyone help me?
Thanks very much

Is a driver installed on the windows environment and is the hardware detected by the OS ?
Once the hardware is detected by the OS you need to make same configuration modification to EXTRA_JAVA_OPTS as you have to do for linux based openhab.

Hi Wolfgang_S
I am using openhab on windows os and I find it different from linux. The address of the file is also different. So I can’t find EXTRA_JAVA_OPTS. Can you help me solve this problem?
Thank you very much.

It is in the service configuration file mentioned in the documentation.

hi Bruce_Osborne
I have read the material you provided but I did not find anything related to EXTRA_JAVA_OPTS. Can you help me?

This forum gas volunteers to help you understand your system so you can maintain it. You found something mentioning EXTRA-JAVA-OPTS in a file. I pointed you to TV he location on your system.

If you could not find it what did you find? Please tell us what you have already tried. We are here to help you, not hand out complete solutions. Most of us here do not run OpenHAB on Windows since it is primarily targeted at Linux and Unix-like systems.

Hi Bruce_Osborne
Thanks for your suggestions
I searched my openhab and I only found EXTRA-JAVA-OPTS in the setenv.bat file (C: \ openHAB2 \ runtime \ bin) and it has the following content:
:: set jvm options
set EXTRA_JAVA_OPTS = -XX: + UseG1GC ^
-Djava.awt.headless = true ^
-Dfile.encoding = UTF-8 ^

So you need to add to that “set” line, likely. I think the ^ lets it span multiple lines to make it easier to read.