Use local TTS with squeezebox on Windows

Tags: #<Tag:0x00007efed9e058b0> #<Tag:0x00007efed9e05068>

… here we go: Use local TTS with squeezebox on Windows

@Fro … I’ve started to create the page (see link in 1st post of this topic). Unfortunately you’ll not find much details about firewall configuration. There are multiple reasons why I’ve decided not to post a step-by-step explanation:

  • I’m not an expert on security & firewall settings; they need careful considerations (how exposed is the system, how “hard” is the service I expose … etc.); do I open only for the port - do I limit access to subnets, or machines …

  • Another point is, I use a German Windows 10 - the screenshots will only be of limited use for other OS versions (e.g. Win 7 with different local)

If you are aware of the risks involved I’ll try to help you to configure the firewall the same way I did for me: open the port for all incoming traffic (my system is not directly exposed to outside networks). For this I would need to know the OS version and language. I’ll try to find a system that matches yours as close as possible and create more detailed instructions I’ll post in the forum.

with kind regards,
Patrik

Thanks for Your help. I tried open outcoming port: 8089 in source PC firewall (first TCP, after UDP), but without luck. Unfortunately this PC is my media server also, is exposed to internet. I have firewall in router also (Asus RT-AC68U) - maybe in router settings is my problem? I don’t know. Still investigating.
Sorry for my english. I’m from Poland. I have Windows 10, same like You - polish version.

Again: Thanks for Your help.
Adam

Hi Fro,

I can not help you with the router - but I assume that no configuration changes are required there. For the windows machine you need to open port 8089 for incoming TCP connections:

Then you should be able to use the service from machines in the same subnet. I do not recommend to expose the service to the internet (by configuring the router). I do not recommend to change configuration on the router - as I assume your squeezeboxes are all in your/same subnet (192.168.1.x) that should not be required.

To open the port for all traffic and all programs is not very sophisticated - unfortunately I can not help you to create a more secure configuration. I recommend to follow up there; depending on your network topology (e.g. NAT, router- & provider firewalls) my configuration might be OK - but it’s a potential attack vector.

I hope this helps to get it flying (or better “speaking”) …

with kid regards,
Patrik

I would like to try the windows REST voice but can not find the RESTTTS-2016-01-01.001.zip file.
would you post this some where?
Thanks