Use Velux Binding in OH 1.x

Hi,

I would like to use the Velux binding in OH 1.x
Is this possible and if so how ? Because lately there is not much information to be found on OH1

thx

Hi,

I know how to copy the jar file into the addons folder. That’s not the issue.
However finding the jar file for oh 1.x is the problem. And following all documentation for the configuration of this binding seems to be for oh 2.x as well.

thx.

Search engines are your friend :grinning:

Thanks. I found following jar which I placed in the addons folder: org.openhab.binding.velux-1.14.0.201903162123.jar And I entered following in openhab.cfg
velux:bridgeIPAddress=192.168.10.11 (which is the ip of the bridge connected through the lan)
velux:bridgePassword=velux123

But upon starting openhab (normally or in debugging mode), I can’t find anything on this binding. It doesn’t seem to be started.

thx

Sorry, no idea, too much time passed since my openhab1 days …

Maybe you have to change the password?

(**) Note: This password is the API password that is printed on the back of the unit. Normally it differs from the password of the web frontend.

Thanks sihui. I changed the pw, but still no luck.
I think the binding is not getting loaded, as otherwise I would expect at least an error message in the log.

There is a post here somewhere from the developer, maybe you can ping him

Will do. thx for the effort.

Did you check? It either is started or it isn’t. There is no middle ground.

Hi,

No it doesn’t start. (Nothing can be found in the log).

Hello,

please try putting the .jar file into /usr/share/openhab/addons and watch the log files.

Best regard, Guenther

Or try grap another (new) copy. If something is wrong with the .jar file, you´ll not be noticed.
I have had this issue a coupple of time. And it seems to have something to do with the way you download the .jar file. If it´s corrupted, openhab wont read it, and you´ll not be notified in the log either.

Hi Guenther,

I’m using a windows machine. So I did put it in the addons folder in openhab. But to no avail. Nothing showing up in the log.

Thanks, I tried downloading it with different browsers, but no luck…

When I download a jar file using chrome browser, it promts me and tell me it´s not safe and ask if I wish to keep it. This is a good indication that the download went well.

If you´re sure about the download, try entering Karaf console and look for the binding. It should show you the velux binding and tell if it has been activated. (I dont know if it´s different in a windows setup).

Last suggestion…
stop openhab, clear cache and tmp. Restart openhab.

@viper1705,

have you already tried to enter the direct link to the jar-file?
This should lead to a file with a size of 493 KB.

Tried that direct link, but it’s the same result.
I used the osgi console to check all the bindings and it seems the binding is installed but not active.

image
I then tried to start the binding through the console, but then I got following error messages

this is the actual error message:

Okay, at least you got an respons/error now. It´s out of my knowledge though… You´ll need @gs4711 to deal with that I guess :slight_smile:

This is strange as it has been fixed with PR#5833. Do you use the official distribution (which waits for the inclusion of this PR) or the above mentioned jar-file?