Using non-deprecated functions with Pushover action

The openHAB2 Pushover docs (article version 2.2) mention a new way of pushing notifications on your rules.
The new functions sendPushoverMessage(pushoverBuilder("test message")), etc seem to be the preferred way since the original pushover(String message) is listed as Deprecated.

The thing is I can’t get my rule to work with the new function but it worked when I used the deprecated one. Am I missing something? Paper UI lists my Pushover action as being version 1.11.0 and the Maven repository lists 1.11.0 as the latest so, where are these 2.2 functions coming from? How do I update to be able to use those instead? :face_with_monocle:

This time the docs are way ahead :rofl:

You need to upgrade to the new pushover binding, either download through this post or install the binding through the market place.

Hmmmm. The 2.2 version of the docs shouldn’t be ahead of what is available in 2.2 release. Something must have gone wrong with the docs build.

At least for the pushover binding docs the initial page loading shows the new snapshot version annotations.
Switching via “Switch Article Version” to 2.2 shows the 2.2 annotations.
Actually I thought this is a new docs feature :rofl:

Yes, this is another problem but it has been raised and hopefully will be addressed soon. It should default to the latest release, not the snapshot version of the docs.

It’s been out awhile but I don’t think it was ever announced. The selector just appeared. :slight_smile:

1 Like

Not sure what the “marketplace” is. I installed the binding through Paper UI. :man_shrugging:t2::flushed:

If you did not upgrade to the new binding version it won’t work. This is done through the market place or the link I posted.

Now I’m having a hard time uninstalling the Pushover Paper UI action; the circling arrow gets stuck and it never finishes. Tried the force uninstall described here (bundle:uninstall <ID>), then restarted the openHAB service via sudo systemctl restart openhab2.service and I still can see the Pushover action listed as installed. Should I just ignore Paper UI and copy the jar you pointed me to into the openHAB-share\openhab2-addons folder?

Nope, two bindings installed will give you problems. You need to solve that problem first.
Try deleting tmp and cache …

Which of these do you mean I should delete?
find / -type d -name "dir"


Usually it´s:


Empty the files inside, bu dont dele the autcual cache and tmp folders.

1 Like