UZB-1 stick does not show up

Hello, I’m trying configure zWave in openHAB 1.7.1 on my MAC (OSX 10.11).
I would like to include the UZB-1 stick in my configuration.
I have successfully configured SONOS and HUE but fail with zWave.
Here’s my setting:
################################ Z-Wave Binding
zwave:port = /dev/cu.usbmodem411
zwave:healtime = 2
zwave:softReset = false
zwave:masterController = false

I have looked up the port by looking at /dev before and after inserting the stick. Only changes I’ve found are cu.usbmodem411 and tty.usbmodem411.
I’ve tried both. No success.
Logxml is extended with zWave logging as recommended.
2015-11-02 21:13:17.642 [DEBUG] [.zwave.internal.ZWaveActivator:36 ]- Z-Wave binding started. Version 1.7.1
2015-11-02 21:13:17.663 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2015-11-02 21:13:17.788 [INFO ] [.z.internal.ZWaveActiveBinding:325 ]- Update config, port = /dev/cu.usbmodem411
2015-11-02 21:13:17.789 [INFO ] [.z.internal.ZWaveActiveBinding:330 ]- Update config, healtime = 2
2015-11-02 21:13:17.789 [INFO ] [.z.internal.ZWaveActiveBinding:384 ]- Update config, softReset = false
2015-11-02 21:13:17.789 [INFO ] [.z.internal.ZWaveActiveBinding:393 ]- Update config, masterController = false
2015-11-02 21:13:17.789 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ]- Initialising zwave binding

Noting happened afterwards.
In HABmin NO device is visible under the zWave Binding.

Anyone out there who has successfully configured UZB on a MAC?


I use the same stick. But not under MacOS but Lunux (Raspberry Pi 2). For me it is working fine (except that habmin did create a second node which is always dead).

Are you sure that your interface is the right one? From the manual of the UZB1 stick it should be " /dev/cu.usbmodemfa131" … quite different to what you are using…

Hi LarsK,
yes, strange. But do you know any other way to find out the name?
Any way I will give it a try with that name.

Well… Under Linux I would remove the stick and reboot. Do a “ls” or “dir” in “/dev” to have an idea what devices are already there… and then plugin the stick and do a “ls” once again. By this way you should find the new one quit easy.

Just did it. Nothing changed. Stick got recognized as mentioned above. But using either one of the names does not make it in openHAB.
Guess I have to wait for someone with a working UZB1 MacOSX combination.
Strange that even the zWave DEBUG log setting does not give any more info.

With some luck @chris (the developer of the binding and habmin) will stumble upon this thread here. I am pretty sure he can at least give you additional ideas where to look at.

Tested UZB1 on a Windows machine. Does work and gets recognized. At least it is not defect.
Hope someone can pint me to a working MAC OSX config.

I’ve used the Sigma UZB stick and it works fine on my Macbook - it’s probably the same as the one (since Sigma make the reference design).

I would tend to go with @LarsK - the port is probably incorrect. The log you post only shows the configuration - shortly after this it should show if the port opens correctly or not - can you post this part of the log as well?

I’m away from home at the moment so can’t test my unit but will take a look when I get home later in the week.

Hi Chris and thx for your reply.
The thing is that there s nothing after the last log entry. It simply just stays with “initialising …”.
As it is working with openHAB under Win8.1 I assume that the stick is OK.
Will test the port on another MAC later.

Tried it on another MAC with OSX 10.10.5

This time the adapter showed as tty.usbmodem1421 and cu.usbmodem1421.
Really strange.
Don’t know any other way to check.
Any ideas?

@chris, is there any other way checking the adapter 's port?
I do a ‘ls’ on the /dev directory before and after I’ve inserted the adapter.

Also is there a more detailed logging available that might give a hint?

No - there’s no other logging available - it should print the result of opening the port, but for some reason it’s not…

I just plugged in my UZB-1 and I get two ports - cu.usbmodem1411 and tty.usbmodem1411. If I remember correctly, you need to use the tty version - not the cu version. Have you tried this? The numbers on the end probably change depending on what port it’s plugged in to.

Same problem here.
The USB stick works well under Windows.
On Max OS X 10.10.5 there is just nothing after “ZWave Refresh Service has been started”.
I tried with both /dev/tty.usbmodemfd131 and /dev/cu.usbmodemfd131 .
I tried to run with root so that permissions shouldn’t be an issue.

Let me know any ideas I could try … I’d be happy to contribute to the solution.

Did you figure out a solution? I am facing similiar problems in Linux.

i have this stick, it installs on /dev/ttyACM0 which regardless if you are root, you need to add the user account that openhab runs under into the dialout group without this you cannot get this working.

I got the same problem like @jensHAB. My operating system is MacOS 10.11.4. Did no one get it run so far with MacOS?

As I said earlier, it works fine on my Mac.