Very slow ZWave network

Another discrepancy to the picture with the network map. There is no node #255 but node #1 is there. Or is the controller #1 AND #255? Maybe :hushed:

2 controllers? :confounded:

Yes, if this rare situation happens it is both … one controller, two node id’s.
But I am not able to explain that :grinning:

I think that is the situation I am having. The controller is #1 AND #255. Maybe it’s related to my problem.
I am not considering buying a new ZWave stick and transferring the settings from the one I have to the new one. I’ve seen an inexpensive SLUSB001A at digikey. Maybe it’s worth a try, though I have not seen much said about that stick.

That is a newer 700 Series stick ( Z-Wave Plus 2) I am not sure it would work with the current binding designed for the 500 Series (Z-Wave Plus) sticks.

1 Like

I don’t think so. In the past when this happened it was not the root cause of problems.
Why not going with @stefan.oh analytics from above:

Get rid of all the nodes which are not present anymore, in addition to that make a soft reset of the stick (shutdown the server, remove the stick, wait a couple of minutes, reinsert the stick and fire up openHAB)

1 Like

Correct, confirmed from Chris:

I don’t think that is the issue. There are gaps in the node numbers because of having had to either replace or re-pair devices. But I do have all the nodes shown in the network and OH shows them all online. I’ve removed one device I thought might be the cause. For a while and after a heal it seemed to have worked.
It was plugged back in my spouse, I’ve redone the procedure and it is still not working.

What I really do not understand, fundamentally, is that the Zwave stick’s lights color change frequency goes down dramatically when the network is in trouble. Doesn’t that mean that on the stick’s side something unusual is going on? The log slows down as well dramatically. Is there a way to see what the stick is doing when flashing slowly?

Many times the nodes do not get completely excluded from the network, leaving zombie nodes on the controller which can mess up the network routing and cause performance issues.

How do you remove them? There is the node75 which I do not know at all why it’s there. It does not appear in the list of things nor in the inbox.

Edit: node 75 has now appeared in the inbox. Does hitting remove there remove it from the stick’s setup?

I normally use SiLabs PC Controller software on a Windows PC. It permits you to see & delete them.

Hi,

I’d agree with Bruce - connect the stick with the manufacturer’s debug software, or close as you can get to it and remove dead, unused, or unwanted devices. This may also allow you to update the controller firmware.

For a few months my Z-Wave network would stop for 120 seconds - clearly a timeout trying to connect to devices that had failed previously. As I use a RaZberry Z-Wave adapter on a RPi, the equivalent is Z-Way which allowed me to mark a device as failed, then remove failed devices. After also upgrading the firmware (several releases behind), my network is now stable.

Chris, mhilbush and others tried to implement the same controller commands to exclude a device, however under 2.5.x HABmin, the feature Remove device from the controller didn’t work for me - hence the need to use other lower-level software.

There’s several posts on the topic if the instructions Bruce posted arent enough (search for Remove device from the controller), but here’s the full-fat tech discussion about adding the exclude commands to openHAB itself:

It took me about an hour to build a Z-Way uSD, configure it, remove the nodes, and update the controller firmware. The USB stick you use should be easier to move to a different computer (ideally in the same location). Well worth considering as a maintenance task (once a year?).
TTFN,

James

I agree with James, removed some ghost devices and did firmware upgrades via z-way too.
Just as a little addition, I installed z-way on the same RPi, stopped OH and ran z-way then.
So no need for another hardware.

Interesting @chris4789 - didn’t know you could install Z-Way on the same OS install as openHAB (only running one at a time). Always learning! :slight_smile:

I guess there’s a trade off between the extra effort of building a separate uSD card for the same RPi, and the slight risk of breaking something on a production install of openHABian.

For other sticks toe OZW Control panel sometimes works. I have not had success in my personal production environment with that though, Miy environment is “unconventional” though.

I have tried the silabs software with not much success. It keeps giving me error to every command I give. It seems to have removed node75 but that’s it.
Also there’s no firmware update for this stick. Version 1.0.0.
There was an attempt at a version 1.0.1 that was apparently pulled hours after it was put out…
I was amazed how terrible the software is. It looks like a 1985 program written by an amateur, but that’s beyond the point.

I’ve got a second stick of the same type. I’m considering doing a full reset of that stick and bringing the active set of things/nodes from the current stick. Is there a way to do that? I fear having to redo the whole setup of my Zwave network as I know how long it takes. Having to go through configuration files and GUI as some items are configured that way and others through text files.

After trying many more solutions, I gave up and did a hard-reset of the control stick and re-included the nodes. I am not finished yet but hopefully this problem won’t creep back.

Well let us know how that goes, you know because this is really bugging me

I’ve had similar issues in the past. I bought a zwave toolbox (Z Wave Toolbox | User's Information — ZWaveProducts) which allows you to perform zwave packet captures and see how nodes are routing in real-time, amongst other things. At one point I had a node that was trying to route through a node that no longer existed and was the cause of timeouts. In the end, I did perform a reset on the zwave controller USB stick and re-add everything and also has been fine since. It was helpful to gain visibility to fully understand what the problem was. Bit of an investment though.

There is no indication what world region that device is made for. That is a big omission on their part.

Yup PC Controller Windows software can delete zombie nodes from the controller without resetting it.