Victron Energy binding]

Continuing the discussion from Victron Energy binding:

Greetings. i have a problem with this binding, a conflict with tty ports on a rpi4.
Is it possible to get some advice to fix it?

What kind of conflict?

Don’t want to hijack the thread here :wink:, but when I saw it I realized I still had a question pending in that last one @jimduchek. I’ll repost here, is there anything I can do about the invalid checksum? Would love to get this working.

I tried the latest jar file on an Raspberry Pi 4 Model B Rev 1.1 running openHAB 3.3.0 - Release Build with just one VE.Direct serial cable attached. Openhab detects the cable, but I cannot see the device connected to it, a BMV-702, in the GUI. I can see all the values in the log, though:

21:40:42.206 [INFO ] [openhab.event.InboxAddedEvent        ] - Discovery Result with UID 'vedirect:serial:VE4WQMJU' has been added.
21:40:42.206 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing 'vedirect:serial:VE4WQMJU' to inbox.
21:44:35.996 [ERROR] [covery.VEDirectDeviceDiscoveryService] - Declaring Unknown Device
21:44:36.929 [ERROR] [.internal.VEDirectSerialBridgeHandler] - vedirect:serial:VE4WQMJU: Invalid block: Csum 6413 !
21:44:36.933 [ERROR] [.internal.VEDirectSerialBridgeHandler] - vedirect:serial:VE4WQMJU: 
PID	0x204
V	24237
I	-2299
P	-56
CE	-10694
SOC	962
TTG	4277
Alarm	OFF
Relay	OFF
AR	0
BMV	702
FW	0311
Checksum	A
21:44:37.017 [ERROR] [.internal.VEDirectSerialBridgeHandler] - vedirect:serial:VE4WQMJU: Invalid block: Csum 6899 !
21:44:37.021 [ERROR] [.internal.VEDirectSerialBridgeHandler] - vedirect:serial:VE4WQMJU: 
H1	-155119
H2	-10695
H3	-130587
H4	2
H5	0
H6	-8658849
H7	10
H8	30891
H9	25463
H10	135
H11	0
H12	0
H15	1
H16	11
H17	21465
H18	23750

Thanks for the reply. I’ll explain:
I use OH 3.4.1 on a RPI4 4g to which is connected an inverter controlled with a program (solpiplog) which takes care of transmitting the mqtt messages and a victron smart shunt to read the battery data, both are connected with a usb serial adapter.
for a few days suddenly without warning and without errors in the log both connections are lost.
if I disconnect (even not physically by deactivating the thing) the solpiplog connection remains active.
I have tried modifying the rules to generate a tty alias but to no avail.
udev rules:

SUBSYSTEM==“tty”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, ATTRS{serial}==“FTGDDU55”, SYMLINK+=“ttyInverter”
SUBSYSTEM==“tty”, ATTRS{idVendor}==“067b”, ATTRS{idProduct}==“2303”, SYMLINK+=“ttyShunt”

in the OH configuration file I modified adding

EXTRA_JAVA_OPTS=“-Xms192m -Xmx320m -XX:+ExitOnOutOfMemoryError”

I can not understand what could depend and would gladly accept advice for the investigation

Thank you