Visual studio code error connecting to server Integrated Basic UI

Hi , i’m strugling to get my visual studo code server to coorporate with my raspberry pi
I followed all instructions and can edit my files on the shared server , but when i try the Integrated Basic UI it gives the error as seen in the attachment, i’m at it the whole afternoon , but need some help please
Who can point me in the wright direction ?

The showed error message is a known und unresolved issue.
BUT it has nothing to do with the BasicUI.
This error is telling about an issue with the language “server” not the complete openHAB environment.

You want to show the basic ui of your demo sitemap in vscode?

yes , just playing around, now using Domoticz and experimenting with openhad (more options possible)

After some testing i get a black screen (which seems your behavior from the screenshot) for my sitemap when the connection settings are not valid.
Are you sure about your IP and Port settings?

yes , triple checked;) tried with name, ipaddress , all the same , what did you mean with language settings ?

Maybe a unnecessary question but:
The sitemap is showing fine when you try it in the browser?

And some general stuff:

Which OH Version, which Vscode version and which extension version are you using?

Also correct port? :grin:

yup , standard 8080

yes browser worked, samba share working in windows 10
OH 2 latest download from yesterday , VSC OH 0.5.1

OK, i am out of simple solutions now, sorry. :smiley:

I will check the code for this and see if we can provide some useful logs for it.

ok, thx

Hey @wen62,

Could you try this extension please?

It contains a new output Channel which should provide logging information.
(I have added this now as a general method, so we can extend user logging in the future easily.)

Should look like this:

Please note that this is just an experimental extension for digging into this problem.
Since it is packaged on my current codebase it may contain some flaws,
so you should switch to the released version, when we have finished testing.

I have actually the same problem. I am in the setup phase of my openHAB installation. Base is a Ubuntu Server 19.10 (minimal) with openHAB, Zulu and Samba. Installed with the official steps from the openHAV documentation. My Visual Studio Code runs in macOS 10.14.6 and in a virtual Windows 10 machine in VMware Fusion. Both VSC have the problem to show the sitemap. But they show configuration error (like an wrong “,”) and also shows in autocompletion e.g. things. Only the part with the sitemap gives an empty output. Opening in the same in Safari on macOS or in Firefox in Windows shows the sitemap.

Hi @iLion and welcome @ openHAB community,

Maybe you could also install the testing extension from my last post and show us the logs output it produces when you try to open a sitemap in basicUI.

I installed on a second windows maschine a fresh Visual Studio Code and the manual downloaded extension from your link. I got no more output, except the following line, when I try to open the sitemap preview: [Error - 08:07:17] Connection to server is erroring. Shutting down server.

What you describe is the openHAB server output, of which I have no influence.

There is a yellow marked drop-down in my screenshot.
You can change the output Channel through this and there should be a Channel openHAB extension available.

Please check if it is as explained and if the extension channel produced some more logs.

Is working perfectly now , thx a million!!!

I see now, excuse the confusion. Now my output is the following:

openHAB vscode extension has been activated
URL that will be opened is: http://openhabeusername:openhabpassword@
Creating new preview panel.
Updating new preview panel now...
Attempting to open Sitemap "standard" in BasicUI.
URL that will be opened is: http://openhabeusername:openhabpassword@
Creating new preview panel.
Updating new preview panel now...

I changed my username in the logoutput to “openhabeusername” and the password to “openhabpassword”. I did not see anything inside Visual Studio Code. But when I copy the original shown url to my webbrowser, i can see the basic ui.

I have changed nothing in the functional code :man_shrugging:
Anyways i am happy that extension is working now for you, even if i would have loved to identify the problem that has lead to it.

Hey @iLion, would be great if you could use code fences in the future.
An explanation of how to use them in this forum can be found here: How to use code fences

This helps bringing code and looks in a nice readable and sometimes even colourful presentation.
Thanks in advance.

OK, this sintence confuses me a bit now.

Which version did work for you in the browser:

This one with user credentials?


Or this one without user credentials?

Hi, both versions copied to Safari in macOS 10.14.6 works without an error message. So first I copy with username and password, but it makes no difference. I can see and use my sitemap in an external browser.