VoiceRSS and Openhab2 Missing API key


Is someone got working voicerss with Openhab2, I have installed voice-voicerss - 2.0.0
configured it with the Paper UI by adding an API Key into Configuration->Services->Voice->VoiceRSS
Set it in configuration->system->voice as the default TTS
Choosen VoiceRSS - french language

And I get the following error message in openhab.log:
[ERROR] [core.voice.internal.VoiceManagerImpl] - Error saying ‘scène standard activée’: Missing API key, configure it first before using

If I put into /etc/openhab2/services a voicerss.cfg with the apiKey in it I get the same error

Do you have some idea?

It is strange like you search for two hours the solution of a problem, you post a question to the forum because you are stuck.
You try a last solution and it works.

I went to Configuration->Services->VoiceRSS->Configure and instead putting the apikey directly I went to expert mode and added the value and clicked save.
It worked

One thing that was strange before going to expert mode it that if I entered the value in normal mode and clicked save and go back to the parameter it was empty.

I’ve been having trouble with this too. I’ve added the apiKey to services/voicerss.cfg and tried using expert mode in PaperUI to set the apiKey (where is that stored?). Neither is working. I still get the “Missing API key” message when trying “smarthome:voice say test”.

Are you able to see the api key when you go to expert mode ?

Yes, I see it in expert mode although it doesn’t display in non-expert mode.