VS Code Error while connecting to openHAB REST API

openHAB extension can’t connect -> Error while connecting to openHAB REST API

host ist set in user and workspace settings: “openhab.host”: “192.168.1.10”

Why?

OH3? Did you read the release notes regarding API Auth?

Yes and No

Then you maybe should. There are plenty of threads with this topic, you also can use the search functionality.

https://community.openhab.org/t/visual-code-and-openhab-3-0/

Bottomline: You now need a Token to use the API.

I have writen down a dedicated explanation for this, since the question will raise up again in the next weeks. :slight_smile:

4 Likes

Thanks so far…works but also had to disable “Implicit user role for unauthenticated requests” as here:Visual Code and Openhab 3.0 - #16 by Confectrician

and also had to reduce the password to numbers and letters. Is that possible?

You could also try generating an api token and set that up as username while leaving the pasword parameter empty in vscode. (Also described in my FAQ post.)

I am using the extension this way and it seems to work quite well.

Perfect…thanks :slight_smile:

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.