VSCode doesn't validate my code

(Mark) #21

I can only assume it’s because of this.

Can you try running VS Code on the openHAB host, or try using a shared folder? I know those configs will work, and may more easily help to determine the cause of the issue.

0 Likes

(Mark) #22

FYI, I opened an issue for the inline validation issue.

1 Like

(Pascal Turbo) #23

That’s the problem. Obviously it only works on shared folders. I’ll open a change request. But the inline validation works for me even on shared folder.

0 Likes

(Mark) #24

What build are you running? It worked up until around September 20.

0 Likes

(Pascal Turbo) #25

I’m running with 2.3.0 Stable Release

0 Likes

(Peter Demus) #26

Hi,

was starting yesterday with VS code. installed the version 0.4.1 from marketplace.

code validation is NOT working using \\openhabpi\openhab240\conf e.g.
code validation is working using X: for mentioned samba share.

https://github.com/eclipse/smarthome/pull/6463 seems to be merged into 0.4.1 …

Don’t know if


was about the my issue or about “never working via SMB share” ?!? :astonished:

BR/
Peter

0 Likes

(Mark) #27

The xtext upgrade from a while back broke samba shares, which had worked prior to the upgrade. My change fixed it for paths specified using a drive letter, but not for a UNC paths. I’m not sure how to fix it for UNC paths.

0 Likes

(Peter Demus) #28

Hi Mark,
created


to help newbies to ease the start using VS code with OH
BR/
Peter

0 Likes

(Peter Demus) #29

…and closed issue again. :open_mouth:

there is already an issue:

even the docs for editors stating:

Attention Windows users: Directly accessing network shares (UNC paths) is often not supported. Please be sure to mount the network share to a drive letter

-> not easy for beginners and not hassle-free but everything okay now

0 Likes