VSCode Slow with LSP

vscode
Tags: #<Tag:0x00007f0147e63c88>

(Angelos) #21

I doubt it
I tried to find a way to completely disable LSP on OH2 but I couldn’t find any.
Maybe we need to open up an issue to request this functionality (an option to disable completely LSP)

try to remove also: bundle:uninstall org.eclipse.smarthome.model.lsp


(Jerome Luckenbach) #22

Hey guys,

Sorry to hear that vscode/lsp doesn’t fit your needs and you don’t want to use it,
but that’s of course your decision and you are free to do so.

Anyway it would be nice if you could keep this thread a bit cleaner.
“How to disable LSP” i not the topic and it seems that there was already a thread which is better for discussions about your problem/solution.

I think there are enough others that still want to us vscode/lsp and want to be informed about the current problems, which includes reading this thread too.


(Al) #23

Sorry @Confectrician, did not mean to derail the discussion thread here :wink:
I am sure that LSP is great for a addition for a lot of users, and I do not want to discourage anybody from using it. Every use case is different.