Wake On Lan -binding is missing

Yesterday I had some sort of issue with one binding. It was causing a hundreds of lines of log data marked with red colour. Hundred of lines appeared in short period of time.
I had to flush a cache and temporary directories. In this point I also upgraded the latest version of OH2.
After this OH2 started normaly, but nothing worked. I noticed that every single binding was in uninstalled state.
I then reinstalled all of the necessary bindings. Everything started to work fine, except for one binding: WOL. It was never listed on the list of available bindings.
Now I can’t turn my TV on automatically.
How should I proceed with this in order to find the missing binding?

Have you enabled legacy binding support?

No, I believe I have not, since it does not sound familiar…

Should I enable it?

If you want to use the WoL binding which is version 1.x, it’s probably a good idea, even if you have forgotten you did this once before.

1 Like

I already thought this was the solution. I’m pretty sure I have never before enabled the legacy 1.0 binding support. I did enable it now, but WOL binding didn’t show up. I even restarted OH2, but it didn’t solve this. It’s like I’m missing something…

The WoL binding won’t appear in the PaperUI add-ons>bindings list offered, without enabling configuration>system ‘include legacy’. Be sure to ‘save’ if changing. Do any other 1.x bindings show up?

Afaik this is not correct, as long as there is no WOL v2 addon, WOL v1 is not legacy. And I have a test setup (legacy is not enabled) and can see WOL 1.14.0 in the binding list

@Petro_Simonen Did you setup openHAB2 in expert mode?

1 Like

No, I did not.

Then maybe the compatibility layer is missing. go to ./services/addons.cfg and change
#package = minimal to packge = expert (mind the missing #)
After expert mode is activated, set the # to comment out.


Thank You. This did the trick!