Wake on LAN with latest versions (Solved)

Hi. Is WOL still working with openhab2?
I’ve enabled legacy mode, installed the binding and configured a widget in the Habpanel.
With the following entry in items:
Switch DesktopPC “Desktop PC Computer” (Status, Network) { wol=“” }

No joy when toggling the switch on the panel. It doesn’t wake the PC. All works fine with WOL using other apps. Any advice?

Okay. Can I simply ask if anyone has this working with the latest versions on windows?

I’ll see if I can get this working on my setup - I’m already looking into CEC so may as well try this too :slight_smile:

Many thanks for this Ganesh
I tried replacing the 255 with a 0. Did not work for me.
I don’t have an asus motherboard, but wake on lan is enabled and works with other wol apps on the lan network.

hmm, I installed the legacy binding, however I can’t add a “thing”, it just gives a blank screen.

I’m a newb, I’ll need to look into editing sitemap now XD

is the wol address an ip address?

Thanks All. I’ve solved it.
I installed wire shark and discovered that using for the subnet broadcast worked. Strange that?

Nice, what’s the difference between the two?

I setup the v2.1 binding and it works great, personally had to set it up for direct IP, but that might be because I have DHCP setup giving IP Addresses.

great work!

Further to this, I was wondering if we could have the status of the PC check if it can receive a ping? and if so, state the PC is on, if not, state it’s off because at the moment the status says “ready” or “ping sent” which is handy to know you sent the ping, but after that, you don’t know if the PC actually turned on…

Mwahaha this is the open source world my friend! We take souls as well as your time!

Not sure what would be more appropriate for checking pc state than ping?