Wall mounted tablet on openhabian not working

  • Platform information:
    • Hardware: raspberry pi 3b + Waveshare Touchscreen
    • openHAB version: 3.0.1
  • Issue of the topic: can’t display main ui on openhabian installation
  • Please post configurations (if applicable):
    Openhabian installation
sudo apt-get install --no-install-recommends xserver-xorg x11-xserver-utils xinit openbox
sudo apt-get install --no-install-recommends chromium-browser

In terminal I start chromium with e.g.

xinit /usr/bin/chromium-browser --no-sandbox --no-first-run --window-size=1920,1080 --url http://localhost:8080

Chromium comes up on the touchscreen, I see the openhab icon in the search bar but rest of the screen stays blank. Any normal website works.
Also tired habpanel instead of main ui but same result.
There is a thread where this setup looks like working but I can’t make it run

Before I had a second pi running the main ui but no matter how I set it up, the performance is so poor, even using a pi 4 with 2gb ram.

Can anyone help please?

Hi,
first of all I don’t think displaying the Browser on your openhabian installation will be the solution to your problem. I would keep the pi with openhabian a dedicated machine.
I have also tried to display the MainUI on my rpi4 4GB with 10’ Sunfounder screen and the performance was horrible. The whole thing just isn’t made for heavy gpu rendering and the hardware acceleration is not always used.
Thankfully, a user in this forum pointed me at an Android distribution for the raspberry: http://konstakang.com/devices/rpi4/LineageOS17.1/
With this, you will be able to have a somewhat enjoyable UI experience for your wall mounted device. It’s not butter, but many times better than any raspian distro with chromium.
Don’t forget to install the Google apps on this thing so you can download chrome frome the play store. You should find some documentation under the link I posted.

All the best,
Bob

P.s.: Here’s the forum link with more instructions: Page rendering speed on Raspberry pi 4 (as a client) - #3 by rpwong

2 Likes

Thank you much for your response.
Sounds promising, I will try it as soon as I can.

Before I made habpanel with openhab work acceptable.

Did you also tired habpanel viewer or fully or just went with chrome app?

OpenHABian is based of Raspian Lite which dies not have the graphical ability to display a browser because the added features are not needed on a server.

Hi Franco
I had now for 6 month what you described and it did work perfectly. This weekend i did a upgrade of my raspi and I have exactly the same problem now. It seems to be chromium which hangs in kiosk mode. Version 78 was fine, version 88 doesn’t work anymore. Even the picture was kind of diagonal. After some tweaking around, if found some hints to set this environement variables to switch of some chromium incompatibilites:

QT_X11_NO_MITSHM=1
_X11_NO_MITSHM=1
_MITSHM=0

Afterwords chromium was working again. But not with OH3M3…

If I use firefox, then it works, but the kiosk mode is not properly implemented there.

Now I changed everything to habpanel and we are almost happy again.

So if somebody understands the problem, it would be welcome…

Best

Chiro

You said it was on openHABian which means the OS in the openHABian image which does not support a browser. You did not say you installed full Raspbian, which means it is on Raspbian and then install the openHABian software. I assumed you gave us accurate information.

Yes indeed but it worked. Just wanted to test it because others made it run. Other website worked but as BobMiles sad, maybe it’s still not good enough.
I just don’t want to accept I need a raspberry pi 4 to just show a website, but looks like it the only way for a well performance.

You may have issues with your local network then.

Thanks for the hint. Just think about trying it again and maybe have further problems in Future.
Just installed lineage os 18.1 and so far the performance in the menue is pretty Good. Just not browsed the main ui yet

Don’t know what chironimo installed but I used the raspberry pi image on the Openhab website so I think it’s openhabian.
Additionally I just installed x-server and chromium

OK you added to it then If there are browser issues it would relate to those added xserver components ot to the browser. You need to seek help on their support forums to fix the browser issues.

I think the lineageOS will do what you need it to! At least I can live with it very well - just habpanelviewer is slowing down after a while for me, so I use fully kiosk browser now.

So chrome on Android is better than chromium on raspberry os? :thinking:

Yes it’s really is. I tested the performance with Speedometer2.0 (browser performance test) and it’s getting a much better performance than any setup I tried for raspberry os.

Also another performance bonus is to boot from a good usb stick or ssd, but I’m not sure if there are issues due to lineage os usb boot is still a experimental feature.

I didn’t find my final setup yet. I will try my new vtran usb 3 stick 128gb which is much faster than sd card

Okay, wow. I installed lineage today and it is like 10 times faster! I think the user experience is really good actually. Sure not like on a modern phone, but really decent and more than enough for a wallmount display :thinking:

1 Like

Hi guys, I wanted to create a small raspberry pi zero w and 3.5" touch panel setup. You think the performance of the RPI zero is too poor for displaying 6 mainUI buttons? No scrolling or anything like this…

Hey, I guess not because I have a raspberry pi 4 4gb and I’m not able to browse like I expect

Lineage os is no option for pi zero so only change would be running chromium on a light installation

Can’t imagine but maybe without any Animations it could work somehow

Thank you for your answer. To be honest this is a little bit surprising. I am using a RPI zero as a digital picture frame and its blurring 5mb pictures into another without any issues.

My goal is only to have a small touch panel and 6 “icons” displayed. Maybe a menu and 6 sub menus.
I will give it a try I guess

Hello Franco,
i think you are right.
The RPI zero w is really slow with normal raspbian os and chromium browser.
I tried it today. Maybe its only because of the remote desktop connection i used. However, i currently have no bluethooth mouse or micro usb - usb adapter to connect a normal mouse.

The Lineage OS you are talking about is faster than the normal raspbian OS or why are you using it?

In which scenario is the RPI 4 still too slow?
I only want to display a menu and a few button with the MAIN UI of OpenHAB 3. Do you think for this it would be enough (or a RPI 3b)?

Lineage os is much faster, I guess it’s related to the much better chrome implementation than with chromium.

If you have just buttons it can work I think. It’s still laggy if you have the main UI pop up menue and changing tabs or pages is too slow for me to feel happy about. I also deactivated all animations but still not like I want it to be.

Maybe with further updates it gets faster or i just go back to the hab panel because it run more fluid for me with openhab 2