[WARN ] [.influxdb.InfluxDBPersistenceService] - Re-queuing 23481 elements, failed to write batch


I am running Openhab on a RPi using the Docker image in version 4.0.4.
I am doing my configuration with the file system and not using the UI.
When looking at the logs I am getting the following error constantly:
[WARN ] [.influxdb.InfluxDBPersistenceService] - Re-queuing 23481 elements, failed to write batch.

I have not enable InfluxDB and actually are not intending to do so. I have not yet found a solution to disable storing data to InfluxDB, or store these values at all.

In my addons.cfg, the persistence section is commented out:

# A comma-separated list of persistence services to install (e.g. "persistence = jpa,rrd4j")
#persistence = influxdb

Is there any way of disabling the saving to InfluxDB?
Or to disable this saving completely?

Looking forward to your input and your help.

Well, that’s super easy. Just uninstall the InfluxDB add-on. Add-on Store → Other → Persistence Add-ons.

Because the line is commented out, it’s assuming a managed config so it’s not touching $OH_USERDATA/config/org/openhab/addons.config. If you don’t want any persistence add-ons, uncomment that line and remove influxdb so it just says persistence =. Or commit to using a managed config and only add-remove add-ons through the UI.

1 Like

Thanks @rlkoshak. I used the persistence =. and it worked like a charm :smiley: