Warn message every 10 minutes : Unexpected state type: StringType from LCN Binding

in my openHab log I get every 10 Minutes this message:
[cn.internal.converter.ValueConverter] - Unexpected state type: StringType
How do I find out what is the couse of this message?

This is certainly triggered by the LCN binding at this line:

DecimalType is expected by the binding.

thank you for the replay,
What do I have to change where? I have almost 30 LCN Things and nearly 100 Items.

I can’t really help more, I do not know this binding. But the binding maintainer would probably help you if he sees your topic. I would suggest to mention LCN binding in your topic title.

thankyou, done :smiley:

I didn’t see your question until now. You can give me a mention next time or add the “lcn” label. Are you still interested in a solution? I would extend the log message and send you an updated version of the binding, then.

Yes please. I still get this error message every 10 Minutes

@fwolter: did you see my replay?

Yes, have it on my TODO list.

I improved the logging. The message should contain the module address, the variable and the actual value, now.

Give it a try: https://github.com/fwolter/openhab-addons/releases/download/lcn-improve-logging-1/org.openhab.binding.lcn-3.4.0-SNAPSHOT.jar

Could you please give me advise how to install this?

Simply drop the JAR file into the addons folder of your OH installation. e.g. under /usr/share/openhab/addons.

Thank you for the information.
The logging does not change I dont see any other or more Messages.
Looks like I do somethiong wrong :smiley:

Maybe the currently installed LCN binding interferes with the new one. You can temporarily uninstall the LCN binding. Things and Items are left untouched.

If that doesn’t help, you could try to clean the cache by running openhab-cli clean-cache when OH is stopped.

now I get a new Message:

 [inding.lcn.internal.LcnModuleHandler] - S000M070: RVARSETPOINT1: Value conversion failed: Unexpected state type: Was StringType but expected DecimalType: Not configured in LCN-PRO: RVARSETPOINT1

You seem to have an Item linked to regulator 1 (R1Var) of the LCN module 70. When OH polls it, the LCN module responds, that R1Var is not enabled in LCN-PRO.