We need your help on testing!

I tried installing latest (snapshot) OH2 with Nikobus binding on rpi2:

  • had previously working OH 1.8.2 (with Nikobus binding)
  • downloaded OH2 snapshot and extracted to /opt/openhab2
  • copied items and sitemap from OH1 to corresponding folders within the OH2
  • copied nikobus binding from addons OH1 folder to OH2
  • copied openhab.cfg and installed feature:install openhab-runtime-compat1x - as described here
  • installed feature:install openhab-transport-serial

Using basic UI I was able to turn on/off lights, dim lights, use window shutters… so in short, it seems to work, at least during my short test…

Hope I included all the steps above, was writing from my head, but the bottom point is that it seems to work.

I will do some more testing and let you know if there are any issues and if I have time, I might create a PR (if someone else won’t do that first :wink: ).

Thanks all for doing a great job.

That would be wonderful - thanks for testing :sunglasses:

So this commit wasn’t needed after all?

Not 100% sure if I can confirm that, but I can confirm that I took the Nikobus binding from the addons bundled with the the 1.8.2 release (https://bintray.com/artifact/download/openhab/bin/distribution-1.8.2-addons.zip) if that answers your question.

Thanks for the answer. Weird that the 1.8.2 version worked. Could you try the version from the master branch, since that will be what is packaged?

A bit late reply, but was on business trip and was not able to test before. Downloaded the jar from the provided link, replaced it within the addons folder, restarted openhab and seems to work. I’ll do some more testing and let you know. Thanks!

1 Like

A short feedback for the beta 3. Even if not yet perfect, my feeling about this version is very good. I have now started my production environment on this version and will see what happens after few days.
Here are the remaining problems I can mention:

  • Very very very slow to start
  • Problems with rules loading at startup, sometimes with errors and the rules are not working at all, most of the time only warnings and rules are working anyway
  • Lack of authentication meaning no remote access
  • Using Paper UI, I encountered at least one time an exception/crash when removing things. I have now moved my things to configuration files and I have no difficulty with Paper UI.
  • Known issues with Basic UI

I can confirm that the MaxCUL Binding is working with OH2. I’d like to get that reported but I actually do not know how this is now working because I actually don’t have any .jars in the Addon Folder anymore.
Could someone point me to how I can fix this or maybe to point me to where to look what files I actually got now?

You can check on the console which bundles are installed (and you can uninstall them through it as well), see the documentation.

I can confirm that Nikobus works on Openhab2 beta3.

Here are the bundles I use to get Max!Cul working.

189 | Active | 80 | 2.0.0.201606200823 | openHAB 1.x Compatibility Layer 192 | Active | 80 | 1.9.0.201606230111 | openHAB Lgtv Binding 193 | Active | 80 | 0.9.0.201606220943 | ntp Binding 197 | Active | 80 | 1.9.0.201606230111 | openHAB MaxCul Binding 198 | Active | 80 | 1.9.0.201606230111 | openHAB CULIntertechno Binding 199 | Active | 80 | 1.9.0.201606230111 | openHAB CUL Transport Bundle 200 | Active | 80 | 2.0.0.201606200823 | openHAB Serial Transport Bundle

Is there a reason why the IRTrans binding cannot get installed via PaperUI? I am succesfully using the 1.9 binding stored in the addons folder.

If the binding is working correctly under openHAB 2, then you could add a pull request like this one:

And also update the docs.openhab.org site with a pull request like this one:

One question around that: I reported three OH1 bindings (Serial, TCP, IRTrans) working back in Februar and @Lolodomo and you kindly worked on all three (i.e. some changes to the IRTrans are in this PR). And the two other bindings are availale in PaperUI. So now I wonder if there is something special with the IRTrans binding?

If just the changes you described above are missing, then I am happy to do them.

I don’t see anything special about the IRTrans binding that would keep it from being installable from PaperUI. It may be that this is the first report since back in February that this specific binding is known to work in OH2 (or the first I’ve noticed it being reported as working). So I think it’s safe to put together a PR that will allow it to be installable via PaperUI (or Karaf command line). And also another PR to the docs to keep them up to date. I will have a look at your PRs if you submit them, and thanks!

John

Hi to all,
I’m playing with "Souliss Arduino based SmartHome Binding"
It’s work fine on OH 1.8.x
I’ve tested it on OH 2 on raspberry v2, and it’s works only with 1.9.0 binding, any previous versions doesn’t works.

Binding was grabbed from org.openhab.binding.souliss-1.9.0-SNAPSHOT.jar

Yes, that’s expected. Since you’ve found that the binding works under OH2, I will create a PR soon to allow it to be installed from the Paper UI.

@watou, I am planning to create the PR for the IRTrans binding this weekend. Happy to also include the Souliss binding.

Thanks, Joerg! Much appreciated. Please also submit a PR/PRs to the documentation in the openhab-docs repo, specifically here and here.

FYI, the IRTrans and Souliss bindings are now included in the nightly builds. I installed the IRTrans and can confirm that everything is working.

@ykutovoy, if you have a free minute, perhaps you can test the Souliss binding? You might want to take a backup of backup of the souliss.cfg file in the Services folder. The installation routine should in theory not overwrite the config, but better save than sorry ….

1 Like