Weather Underground Binding - configuring metric and imperial units and Fahrenheit vs Celsius

I have the WU Binding installed and reporting from my Personal Weather Station located at my house. Problem is, Celsius does nothing for me. Is there a way to convert the measurements to U.S. formats? Thanks

please read the docs:

  • language definition in the thing configuration (but I guess its english anyway? :wink: )
  • unit definition in the items configuration
  • please also have a look into your WU MyAccount online, there’s some configuration also which has influence on how the API reports for your API key
1 Like

Excellent! Thank you @binderth… I will check into those things you suggested.

and please report back, if it worked - or not. others looking for the exame things will heart you! :wink: (but normally, the whole world wants to display real units - not those fake ones :stuck_out_tongue_winking_eye:)

Haha! You got it. I’ll check into it later today.

Reporting back… I went into the Things configuration and was able to edit the temperature from C° to F°. Working great!

1 Like

just changed the Topic to be more relevant for searches

1 Like

I have the same issue, however I do not find a way to configure the unit in the .items file following the example in the documentation.

Number:Temperature Temperature "Current temperature [%.1f %unit%]" <temperature> {channel="weatherunderground:weather:CDG:current#temperature“}

The value of this item is always displayed as Fahrenheit, whatever I put in as %unit%. In other bindings such as Weather it is possible to add something like ‚unit=fahrenheit‘ - how would I do this in this case?
Thanks for the help!

I don’t know about the %unit% trick, it seems there was a change in the binding or even in the distribution for this?
which version do you use? 2.3 with snapshots or 2.2 stable? (my guess is on the latter?)

  • if 2.2: please change the version in the docs (the docs always display latest version, here 2.3 unstable), you have to edit the unit in the channel: Type temperature : current#temperature [ SourceUnit="F" ]
    the %unit% trick won’t work in 2.2.
  • if 2.3: Perhaps someone with a 2.3 WU-binding experience could help out here? what’s the %unit% thing all about?

ah! missed that one: it’s second on Kai’s post:

I am using 2.3.0- Snapshot # 1246. I saw the %unit% parameter the first time, too, and it is from the current documentation of the binding. Thanks for the description of the way to do it in 2.2 as I was looking exactly for a way to do it in the channel, but couldn’t find it anywhere. Will let you know if it works.

Hi, in openhab 2.3 %unit% doesn’t work seem to work for the wunderground binding. I may be obtuse but I looked at the links provided, and wasn’t exactly clear how to set %unit%. But anyway, in the items file, if I have an item defined like this:

Number WU_MaxForcTemp2day "Forecast Max 2day [%.1f F]" <temperature> (weather) { channel="weatherunderground:weather:local:forecastToday#maxTemperature" }
Then it still appears in the PaperUI, or in my sitemap, in Celsius, but with an “F” after it. I also looked in the wunderground API page for my key, but I don’t see anyway to change the default units there.

OK I looked a bit further and figured out it. To save other people from reading all the links, I think I was confused because I had a number of items like

Number Temp_xxx

and didn’t understand properly that you now have to change them to a Temperature type, as in

Numeber:Temperature Temp_xxx

And for the %unit% setting, it is somewhat buried in the PaperUI under Configuration->System->RegionalSettings. Even that is not enough you have to click on Show More and then you can see the unit menu to set.

It would be nice to update the OpenHab doc to refer to the new Units in the Number setting. The examples are from 2.2 and still use Number variablename, so it is a bit confusing…

1 Like