Weather underground binding not working

I’m trying to have the Wheater Underground binding working on openHab2 on DSM synology and can’t get it to work

I install the binding ok, then I had a thing. The Thing config has an extra parameter that is not mention in the documentation wich is “location of weather data”. What should I enter there???


I have register for the api key and anter it properly…

I cannot locate any config file anywhere… I am lost…

Please help

I’d say that would be the location from which you want to have the weather reading. In the Docs it is referred to as “location”.

No. Location is another parameter and I yes that is in the docs and got it ok.

Where is located the config file where the binding config is located for this binding? It’s not wheater.cfg because that file stay the same always.

That’s odd. There should be 4 config parameters visible in Paper UI.

Location of Weather Information
Refresh interval

Here’s what my binding config looks like.

Ho my god… I’m so dumb… I was entering location in the other location field that is not in the configuration parameters… wich is a field just to enter where is the « thing » in the house…

Thank you! It’s online now!!!

1 Like

So is my location my zip code? What should I put there?

It can be the zip code, or a variety of other things as described here.