WeatherUnderground binding fails to install

Tags: #<Tag:0x00007fc8f648b3d8> #<Tag:0x00007fc8f648b310>

Hi,

I tried to add the WeatherUnderground binding via the PaperUI but it didn’t work. The install process simply never stopped. Fair enough, when closing PaperUI and opening it again, the binding still shows uninstalled.
But since then I get this error message in my openhab.log:

2018-06-19 07:16:29.072 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-weatherunderground’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-weatherunderground; type=karaf.feature; version="[2.3.0.SNAPSHOT,2.3.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-binding-weatherunderground)(type=karaf.feature)(version>=2.3.0.SNAPSHOT)(version<=2.3.0.SNAPSHOT))" [caused by: Unable to resolve openhab-binding-weatherunderground/2.3.0.SNAPSHOT: missing requirement [openhab-binding-weatherunderground/2.3.0.SNAPSHOT] osgi.identity; osgi.identity=esh-binding-weatherunderground; type=karaf.feature [caused by: Unable to resolve esh-binding-weatherunderground/0.10.0.SNAPSHOT: missing requirement [esh-binding-weatherunderground/0.10.0.SNAPSHOT] osgi.identity; osgi.identity=org.eclipse.smarthome.binding.weatherunderground; type=osgi.bundle; version="[0.10.0.201804271558,0.10.0.201804271558]"; resolution:=mandatory [caused by: Unable to resolve org.eclipse.smarthome.binding.weatherunderground/0.10.0.201804271558: missing requirement [org.eclipse.smarthome.binding.weatherunderground/0.10.0.201804271558] osgi.wiring.package; filter:="(osgi.wiring.package=org.eclipse.smarthome.core.library.unit)"]]]

Apparently OH tries this every minute.
I’m running 2.3.0SNAPSHOT

Can anybody tell what I’m missing to get the binding installed properly?

Thanks
Matthias

WU doesn’t provide a free API key anymore, are you sure this is the one you want to install?

I wasn’t aware of that. But also explains why I get the error on the other weather binding!
However, the problem now is how to get rid of it?
In PaperUI it shows uninstalled, I connected via Karaf and also there it shows uninstalled. But still I get these errors in my log.

Thanks