WeatherUnderground thing stuck at INITIALIZING

I’m on OH build 1332.

In the latest ESH stable, there was a change to the Weather Underground binding that requires a bridge. While I understand the reason for the change, I find the lack of backward compatibility unfortunate for the majority of users who don’t require multiple weather things.

I deleted my existing thing, then added a bridge, which is showing ONLINE. However, after adding a local weather thing, the thing is stuck at INITIALIZING.

There’s nothing in the log that gives any clue what’s wrong.

Anyone else seeing this behavior?

I was in favor of backward compatibility too but it is not what was finally decided.
I have not yet moved to a snapshot including this breaking change.
But I know a fix was already provided. I don’t know if it is included in the snapshot you are running.

Yeah, I see it now. Thanks. Very frustrating…

I tried the last build (1334), which I thought would include the latest ESH stable (287), but it still doesn’t work. Ugh.

I’m seeing a different issue. See my comment here.