Web Frame Card not working with HTTPS connectiong to openHAB?

I have struggled several days to see any content in the web-frame-card widget. I have now found that web pages are only shown when I connect to the openHAB server by using http.

Connecting to port 8080:

Connecting to port 8443:

Also I can’t use the Web Frame Card for Web Sites using https. I get a “connection refused” answer or a “website not available” message.

Am I missing something with the openHAB server setup or is it a known limitation?

Many thanks

I am not familiar with the web frame card.

However I am guessing you have to enter a url to display?

Can you share that detail?

This sounds like an issue withe the url being http and not being allowed via https?

You might try relative url.

For the web page that is working when conntecting to openHAB on port 8080 it is an address in the internal lan (but doesn’t matter if it’s just http:)

for the https: connection it is simply a try with google

My only thought would be an issue accessing a secure page in a non secure page?

Have you tried accessing openHAB via https on port 8443?

I had a similar problem with Floor plans via https and removed using relative url. But thstvwoukd nit work you you as you accessing external url.

OK, part I is solved. Sure, it’s the browser setting “allow insecure content” and isn’t related to openHAB.

I still wonder why I can’t get a url with https: to work, no matter whether it’s internal or external

That depends on the web page. A page can send headers that forbids the browser from embedding it in another page. The decision is ultimately up to the browser, but most, if not all, of them respect those headers and refuse to render the page.

Edit: se here for more info

Thanks for the link. Luckily I have no imminent need to display external web pages. But good to know that there might be some obstacles.