Web UI api url change not working


I just tried to start a local development environment (MacOS) of the web ui (frontend only) but I after I start the fronend via npm start I’m not able to access OH since the api url (OH_APIBASE) to my OH instance is not used.

I tried setting the OH_APIBASE variable via cross-env in the npm dev script and also replaced the default http://openhab:8080 in the webpack.config.js with my own url.

But every time I start the frontend the web app tries to access the rest endpoint on localhost:8080

Am I missing some essential step to change the backend OH instance?

Edit 1:
I tried starting the dev server with the latest versions of node v12 as well as v16 but the results with both versions are the same as described before.

The way it has worked for me is by providing the setting in front of the npm start like so:

OH_APIBASE= npm start

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.