Webview bugs?

I’m currently using webview on my sitemap.
I’m using this for different webcam. The problem only occour in the IOS app. Works fine thru android or browser.

My sitemap is:
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=1” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=2” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=3” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=4” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=5” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=6” height=6
Webview url=“http://192.168.x.xx:8080/video.mjpg?oid=7” height=6

It seems like it’s limit how many webview row you can have.
As you see the site map the webview display the first 4 and the repeat the first 3.
To clearify more it display follow:

Webview is basically broken on the iOS app, unfortunately. I gave up and use mobile safari with client side authentication.

Any news here?
My sitemap with

Webview url="http://<cam-ip>:<port>/videostream.cgi?user=<username>&pwd=<password>&resolution=32&rate=0" height=15 label="Cam 3"

works with my iphone app and also Safari (ios), Firefox (win 10), Chrome (win 10) while it instantly crashes the ios app on ipad. Does anybody know a solution?

1 Like

Please try beta ios app
Webview was reworked there


New testers are not accepted

1 Like

Everybody can be a beta tester. There are no limitations. At least there should not be one.

Install the TestFlight app and then follow link on openhab-ios GitHub page

1 Like

Managed to install openhab app within TestFlight but there’s no difference. Webview is also not working

“not working” or crashing the app?

If I understand you correctly yes it sounds like a bug or it may be a iOS limit in the way openhab uses the apple framework. It would be good to work out if it is a bug before working around it and doing the following…

Then why don’t you do it with a single webview like this example I wrote just for you :slight_smile: Second time I have had to answer this week…

Don’t know if you answer was to me or @FrankR ?
But anyway this issue is working fine on the beta version :grinning:

Multiple Webviews with height=15 are working fine for me on iPad with the latest build, at least on the simulator.

@FrankR If you’re still having problems, please create an issue in the github repo and provide more details, thanks.

The Webview is not working within beta ios app if you are not connected to your local URL

Are you trying to do this from your “LAN” or from external internet connection (connect thru myopenhab )

Just tried it, works with remote URL for me.

I am connecting thru myopenhab

I see.
As I understand this is not supported.
myopenHab only support items that’s is available thru REST API only.

Not here. Neither within iphone 8 nor with ipad, neither with normal app nor with beta. Are you sure you are not connected to the local URL? Did you see this one:

Absolutely. I tried in the Xcode simulator and had to change the local URL to a non working one to force remote connection.

Do you get any output or just blank space?

Just a blank screen

Sorry, I was writing from my phone, as I’m not at home anymore, and missed that one.

If this is indeed a local URL it will of course not work.

@FrankR if that’s the case you’ll either have to use VPN or use a public URL for your cam.