Weird rrd4j chart values on y-scale

I guess my first Topic got deleted :thinking:

  • Platform information:
    • Hardware:Raspberry Pi 3b+
    • OS: Openhab 2
    • openHAB version: the newest one (08.02.2021)
  • Issue of the topic: I have exponential numbers on my y- scale when I’m trying to display my temperature and humidity in a chart on my sitemap.

@opus, maybe you couldn’t see the files I have provided you in my last reply…
I’m still very thankful to you, helping me with that topic. And also @rossko57 , that’s very kind of you.


Number openhabianTemperatur “Temperatur [%.1f °C]” (gTemperatur) {channel=“mqtt:topic:Temp1:Temperatur”}


Number openhabianLuftfeuchtigkeit “Luftfeuchtigkeit [%.1f %%]” (Charts) {channel=“mqtt:topic:Temp1:Luftfeuchtigkeit”}


Strategies {
// for rrd charts, we need a cron strategy
everyMinute : “0 * * * * ?”
everyDay : “0 0 * * * ?”
everyWeek : “0 0 0 * * ?”
everyMonth : “0 0 0 0 * ?”
everyYear : “0 0 0 0 0 ?”
Items {
// persist items on every change and every minute
openhabianTemperatur : strategy = everyChange, everyMinute
openhabianLuftfeuchtigkeit : strategy = everyChange, everyMinute


Weather.items=openhabianTemperatur, openhabianLuftfeuchtigkeit


sitemap Temperatur label=“Terrarium” {
Frame label=“Wetter” {
Text item=openhabianTemperatur label=“Temperatur” icon=“temperature”
Text item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit”
Frame {
Group item=Charts icon=“chart” {
Frame label=“Temperatur” {
Switch item=Schalter label=“Intervall” mappings=[0=“Stunde”, 1=“Tag”, 2=“Woche”, 3=“Monat”, 4=“Jahr”]
Chart item=openhabianTemperatur label=“Temperatur” period=h refresh=10000 visibility=[Schalter==0,Schalter==“Uninitialized”]
Chart item=openhabianTemperatur label=“Temperatur” period=D refresh=10000 visibility=[Schalter==1]
Chart item=openhabianTemperatur label=“Temperatur” period=W refresh=10000 visibility=[Schalter==2]
Chart item=openhabianTemperatur label=“Temperatur” period=M refresh=10000 visibility=[Schalter==3]
Chart item=openhabianTemperatur label=“Temperatur” period=Y refresh=10000 visibility=[Schalter==4]
Frame label=“Luftfeuchtigkeit” {
Switch item=Schalter label=“Intervall” mappings=[0=“Stunde”, 1=“Tag”, 2=“Woche”, 3=“Monat”, 4=“Jahr”]
Chart item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit” period=h refresh=10000 visibility=[Schalter==0,Schalter==“Uninitialized”]
Chart item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit” period=D refresh=10000 visibility=[Schalter==1]
Chart item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit” period=W refresh=10000 visibility=[Schalter==2]
Chart item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit” period=M refresh=10000 visibility=[Schalter==3]
Chart item=openhabianLuftfeuchtigkeit label=“Luftfeuchtigkeit” period=Y refresh=10000 visibility=[Schalter==4]
Frame label=“Wärme” {
Switch item=openhabianSteckdoseC label=“Wärmelampe” icon=“sun”
Switch item=openhabianSteckdoseA label=“Heizkabel” icon=“heat”
Frame label=“Regen” {
Switch item=openhabianSteckdoseD label=“Regen” icon=“rain”

that’s how it looks:

I did read the old post and did reply, however you missed that one.
I do need your .rrd files. Just change the extension to an allowed one (I’ll change it back). You can send them im a PM to me.

BTW: There was a forum-wide problem, the last two days of posts are missing. So it is nothing special in your case!

Can I change the extension in Visual Studio Code and how can I contact you as PM?

BTW: There was a forum-wide problem, the last two days of posts are missing and some cumulative data on each accont. So it is nothing special in your case!
Ah okay, I thought it was, because I created two accounts, because they both got deleted…

You can change the extension in an explorer (windows?) or in VSC.
In order to PM me click on my icon, on the next screen you get a blue “Message” button.

maybe I’m just incompetent, but I don’t see any blue massage button

you got an PM from me (and one someone else, hence the green “1” on your icon).

Both your .rrd files are NOT using the setup from your rrd.cfg.
Instead of GAUGE they have a COUNTER, they have 2 archives ( 480 values per minute, 144 vales per 10 minutes) all calculated as AVERAGE!

If I delete the .rrd files, my newly created files are using your rrd4j.cfg as posted above! Filesize would be 48K.

The values you saw were the “correctly” stored values of a COUNTER ( from the docs: Please note that the persistence extensions will return difference instead of the actual values if you use this type; this especially leads to wrong values if you try to restoreOnStartup!). Although a correct value of 28 (degrees) is sent to the db, rrd4j calculates a “difference”.
I have never used anything else then a GAUGE!!

1 Like

Thanks for you’re answer, I’ll try it next morning.
But I did already delete those files before and it didn’t change. Maybe I’m just deleting them the wrong way.
I used Win SCP to enter to my Raspbian. Then I did go to the folder, where the .rrd files are stored and I deleted them. Then I rebooted the Raspberry pi but it didn’t changed. (That’s what happend the last time -> I’ll try it again next morning, but is it the wrong way, how I delete it?)

I"m deleting from a Windows Pc connected via a Samba share.
If you restarted and deleted (in that order), it would be the safest way. Starting with the delete could result in a newly created file BEFORE the shutdown.

When I use the Samba share on my Windows, I can’t reach thefolders of the .rrd files. I can access the folders f.e. with the items, persistence, service, sitemap, things…, but I can’t connect to all the other folders of the Pi.

Therefore I’m using Win SCP, but it would be nice. If I could also use the Samba Share to add a “Netzlaufwerk” (=Network Drive I guess)

Hmmm, I tried it that way:

  1. Entered Win SCP /var/lib/openhab2/persistence/rrd4j/ → deleted “openhabianTemperatur.rrd” and “openhabianLuftfeuchtigkeit.rrd” (both 6KB files).
  2. Then connected to my Raspberry Pi via Putty and executed

sudo reboot

  1. After the reboot I started mosquitto vwith the command


  1. Now I’m connected with the ESP and get the data from the DHT.22
    → I got new .rrd files in the folder “rrd4j”, but still 6KB files.
    → on my sitemap I still have the same exponential numbers

Maybe openhab2 has a problem with other cfg files in the services folder (just a idea I literally have no experience with that stuff)

In the following I list all the files I got in the services folder:
addons.cfg; dashboard.cfg; rrd4j.cfg; runtime.cfg

If you would have used an openhabian Image the samba Setup would have been done.
Remotely I can’t see why the rrd4j cfg isn’t used. Setting the rrd4j package to DEBUG and restarting openHAB should give more hints in the log.
The trials you did with deleting .rrd files and then restart most probably did not give a different result because the .rrd where created BEFORE the reboot.

Sorry, what was the comand again to set the rrd4j package to DEBUG?

I found this page, but there’s only discribed, how to display the log.

Sorry, I forgot about the data-loss

log:set DEBUG org.openhab.persistence.rrd4j

Hello, sorry for my absence the last days, hat a lot of stuff to do and was a bit frustrated by the problem.

Maybe you guys don’t like to hear it, but I gave up.
I thought about setting up a completely new system with the help of the “original” openhab tutorials.
No I have the newest Openhab version (some openhab 3), and it finally works. I copied all the items, the sitemap, the rrd4j.cfg and the rrd4j.persist and now i get the temperature and humidity displayed right.

I mean that topic couldn’t get solved and I wouldn’t discribe my reinstallation as a “solution” but thanks for your help!!!

I have a last question. Would you recommend running Influx and Graphana on my Pi? I have the Raspberry Pi 3b with 1Gb ram, a 64gb micro SD card and I’m thinking about moving my root to an USB Stick instead of the SD card.