Wemo dimmer switch not auto-detected

Hi Hans,
First of all thanks so much for this binding. It’s unfortunate that Openhab doesn’t provide this already. I’m still having an issue with your latest binding though. The issue is that if the dimmer is switched off, there is no way for Openhab to turn it on and dim/brighten the lights. However, once the switch is on I have control over the dimmer. Any idea on what’s causing that? I know this is an old thread, maybe you’ve done some work on it since. Anyways, any response would be great, thanks.

When did you download the Binding ?
I received a Dimmer switch in December and was able to implement missing functionality, so from my perspective, my latest uploaded version should support the Dimmer completely.

Sorry, I feel I am using an older version of your binding. Let me have a
look at the entire thread discussion tonight and I’ll try again.

I would like to thank you for all your hard work on this. I read the whole thread and saw what you needed to do and followed it exactly. And, there they were in my inbox! Just like that. I had my two WeMo dimmer switches recognized in openHAB2, and they worked just as expected. Now, I am trying to get some Leviton Decora switches recognized. I hope I can find a thread regarding those switches that is as good as this one. Keep up the good work, and thanks again.

Thanks for your reply. Glad to hear that it works as expected.
I am still working to get it into the distribution, but hardly find the time for it.

hello, what is the difference between the 0.9 snaptshot and the 2.4.0 in paper ui? I notice in the openhab doc that dimmer are working, but when I installed 2.4.0 instead of 0.9, my dimmer binding stop working.

thank you

0.9-snapshot is the internal Eclipse Smarthome version of the Binding. So actually, openHAB 2.4 shows ist as a 2.4 Binding, but in fact it is 0.10-snapshot version.
With the actual reintegration of Eclipse Smarthome into openhab, there will be no more differences between versions. this should happen with upcoming openHAB 2.5.

I removed the 2.4 Wemo Binding using PaperUI. Then I added org.eclipse.smarthome.binding.wemo-0.9.0-SNAPSHOT.jar to /usr/share/openhab2/addons. What am I supposed to do next ? I went to Paper UI - Add-ons and under binding it is still the Wemo 2.4 binding that is listed. In Configuration - Things my 3 existing Wemo light switches are not working and when I try to discover new items the dimmer doesn’t show up. What am I missing here ?

Did you download it from my earlier post?
What firmware is your Dimmer-Switch running?

I went on github page for assistance and found that installing sonos binding would solve problem. now it works. thank you!

Hi all,

I’m grateful for this post, as it solved my issues detecting the Wemo dimmer. However, I’ve since noticed that my openhab.log file is getting inundated with log messages from the dimmer. I’ve set up filters on both the events and openhab logs, but these messages refuse to to be filtered no matter what strings I add to the filters:

19-03-05 19:38:38.551 [INFO ] [nding.wemo.handler.WemoDimmerHandler - 
GetNightModeConfiguration response '<s:Envelope 
<u:GetNightModeConfigurationResponse xmlns:u="urn:Belkin:service:basicevent:1">
</s:Body> </s:Envelope>' for device 'wemo:dimmer:Dimmer-1_0-xxxxxxxxxxxxxx' received

I used “wemo:dimmer:Dimmer-1_0-xxxxxxxxxxxxxx” as the filter string, and I know it’s working because it removes all of the other Wemo dimmer log messages. The only thing I can think of is that this message is being treated differently because of the line breaks. But even then, I would think that any lines that match the filter would be left out.

Any help with this would be much appreciated! These messages are popping up every two minutes, so there are a ton of them in the log.

In KARAF Console enter

log:set WARN org.eclipse.smarthome.binding.wemo

This will filter those info messages. Please note that this binding Version is experimental.

I haven’t tried using the Karaf console yet, so I guess that’ll be the next thing for me to learn.

FYI, the experimental binding is working great for me, though I haven’t tried using the Night Mode or Fade channels. I had already installed the Wemo 2.4 binding and detected all of my other devices, but it was relatively easy to switch out the binding. I’ll sum up the steps for anyone else who comes into this conversation late like I did:

  1. Uninstall Wemo Binding 2.4 (Paper-UI > Add-Ons > Bindings)
  2. Install Eclipse IoT Marketplace (Paper-UI > Add-Ons > Misc)
  3. Install Sonos Binding 2.4 (Paper-UI > Add-Ons > Bindings)

Once I did that, the Wemo Dimmer popped up in my Paper-UI Inbox, and my other Wemos continued to function. There was no need to re-add the original Wemo Binding 2.4.

Thanks for all of your efforts!

I truly appreciate your time and dedication HMerk!

Hi Hans,
Thank you and everybody else for all this effort. I have managed by myself to get some things working with openHAB but I am still quite novice. Where should I download your patch for wemo dimmers on a mac? (directory path) Is it ziped or plain text?
Thanks again

It is not a patch, it is a test version of the binding with some functions implemented.
Download can be found here

Hi Hans, I’m also new to OpenHabian and able to drop the Jar file in the add-on folder, however looking at the log viewer I’m receiving the below:
2019-10-17 20:28:57.938 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.eclipse.smarthome.binding.wemo-0.9.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.smarthome.binding.wemo [207]
Unresolved requirement: Import-Package: org.eclipse.smarthome.io.transport.upnp
at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

Thanks Mark for the quick response.

I made a small progress. I downloaded your binding. I moved it to the same directory the old “*wemo.jar” was stored.

Since paperUI didn’t register it, I rename it as the old file. When I attempted to install it a large number of error messages appeared on the terminal.

I just downloaded openHAB 2.4 only days ago. That is the version I am currently running. I made progress with my wemo mini plugs and switches and my wifiled lights guessing java. I also have two dimmers. Should I install a different version of openHAB for this new binding ? Or did I miss a step?

Thanks again


Easy way: install SONOS Binding, even you don’t need it.
The binding is Missing the UPnP Bundle, which will be installed with SONOS.

1 Like

See my last post.

1 Like