Wemo Motion Sensor Error - Invalid Subscription ID

Has anyone else seen this error in the logs?

23:23:21.416 [ERROR] [g.jupnp.protocol.sync.ReceivingEvent] - Invalid subscription ID, no active subscription: (IncomingEventRequestMessage) NOTIFY /upnpcallback/dev/Sensor-1_0-221248L0101D5B/svc/Belkin/basicevent1/event/cb SEQUENCE: 2

I’ve used the motion sensor before and it worked fine. Just recently rebuilt openhab 2.0 and started running it on a new computer. Everything works perfectly, including other wemo products. But I just noticed that when I try to use the motion sensor, it no longer responds in the Controls menu. It shows up in the inbox okay. And it connects okay. It just doesn’t seem to sense motion.

The Motion Sensor does work in the Wemo app.

This might happen after a restart of openhab. The event subscriptions have a due time of 10 minutes i think, so after a restart, there still might com notifications with old id’s.

So I would suggest to stop openHAB, wait 10 minutes and start again.
There had been some changes with subscriptions which I have to have a look at.

Okay, I’ll give this a go tonight and see if it resolved the issue. Thanks @hmerk

@hmerk hmm, still doesn’t seem to be working. Very odd. All of my other wemo devices are working fine.

Ich will check again with my installation and IDE. Will keep you in loop.

I’m planning a fresh install of everything today (just upgraded my server) so I’ll see if that makes a difference.

hey @hmerk so I tried this again. New computer MacOS, new 10.12 Sierra install. Fresh everything. Reinstalled openHAB 2.0 online version (instead of offline which I was using before). I fired it up, added the WeMo Motion Sensor, and it worked! Everything was going great. I could see the Motion Sensor in the Dashboard. When I walked by it, I saw the switch move to ON.

Then I decided that I wanted to run it in a tmux session so I could access it over SSH. I shut down / logged out the openHAB server. Then started a tmux session and ran it again. Now it no longer works again, same as before!

Any thoughts?

EDIT: I should also note, I left it off for 30 or 40 minutes before restarting the openHAB server. This didn’t seem to resolve it.

Hi Russel,

to be honest, no clue at the moment.
I will have to find some time to track this down and find a solution.


thanks! I’ll keep tinkering to see what’s going on. Odd that it works on a fresh install until the server is cycled…

okay, I tried it one more time. Just bought a Raspberry Pi 3. Installed openHAB on the newest version of Raspbian. The only thing I added was the WeMo Motion. Same thing happens. Fresh install of openHAB, run it, load in the WeMo Motion. Everything appears to be working fine. When I restart the machine, it stops working.

We are actually reviewing an update for the WeMo Binding that hopefully solves this issue as well. I keep you updated when it will be available.

1 Like