i am a little curious

in OH2 Build 365 automatic discovery found my wemo insight … I just added it and it worked out of the box
could switch it and read the data like power consumption

in the current OH2 build still auto discovery finds my wemo and I can add it … but then on any UI the tile for wemo shows nothing…

what I am doing wrong?


Without knowing your item/sitemap and thing definition, it is hard to tell what’s going wrong.
Even the debug log would be helpfull.
Please note that there is a new pull request waiting which extends the binding in many ways.


well basically no custom configs at all. download …unzip … run … discovery…

old OH2 build add wemo thing … worked without any further custom stuff - wemo could be turned on off

current OH2 build add wemo thing … clicking on thing afterwards on default “basic ui” just shows nothing

as i understand oh2 that should be it… all done from paper ui and handled in mapdb … custom stuff just optional?

thanks for you update on whats coming :slight_smile:

Thats not my understanding,
I have a sitemap ad item definiton which is used by basic ui.
After thing discovery, i link the channels to the items within paper ui.
I then see the WeMo’s in basic ui and can control them.

Best and a Happy New Year

Well the current build of OH2 seem to have an advanced mode Option in the preferences of the paper ui…
Disabling that does indeed bring back the zero conf wemo … Without adding channels and stuff it works