Which Raspi 4xx for OpenHab?

Tags: #<Tag:0x00007efec909b8d8>

Which Raspi 4 do you recommend for an extended OpenHab Installation with more the 100 devices?

  • Does it make sence to get 8 GB or is 4 GB sufficient?
  • Are the problems with USB-Ports fixes by now or to I need a hup?
  • Is there any advantage in getting the Raspi 400 Version?

thx,
Ferdinand

I ran openHAB2.x on a Raspberry PI with loads of bindings (24), items (>1300) and rules (100KB in 32 rules-files) without a problem.
I now run openHAB3 on a Raspberry Pi4(4GB) also without a problem, i only extracted 4 bindings onto a seperate Raspberry (Pi3), because it’s serial connections (RS232 to USB) and I wanted to have the Pi nearer to the devices and not use 3m of serial cables anymore.

So, my bet is 4GB is sufficient, but what do you mean with “USB-Port” fixes? …I don’t think the slightly higher clocked processor in the 400 is worth it.

1 Like

Thank you Thomas.
That helps.
With USB-port fixes I referred to some info here somewhere that there was a bug in openhabean that caused problems with a usb stick directly plugged into the port.

Kind regards
Ferdinand

I don’t have problems with USB-ports, except the usual Linux behaviour to assign /tty_USBx randomly, so I wrote some UDEVs for the bindings, which require a tty-port.
but apart from that - you’ll need a stable 5V/1.2+A powering of the Pi - with that I had 4 USB devices on my RPi3 running without the need for a powered Hub.

1 Like

Ah danke. Gibt es ein zu den UDEVs eine Doku? Bin nach ganz neu und wollte einen Zigby-Stick Conbee II ansteuern und werde das dann ja vmtl auch benötigen. Hast Du vllt auch eine hardware-Empfehlung für die Einbindung von EnOcean-Devices?

Thx. Is there any documentation for writing those udevs for beginners? I want to integrate a zigby stick Conbee II and will probably need that too. Any recommendations for enocean devices?

Schönen Gruß,
Ferdinand

you have to search for distinct attributes and use them to “find” the USB device and then you can add an symlink for your device, which you then can use for configuration, if the binding needs an tty and doesn’t communicate on USB level.

I don’t use zigbee or the likes! :wink: but there’s loads of people here using them!

1 Like

The bug is when an Aeotec Z-Stick Gen 5 is plugged into a Pi4. It’s an actually an Aeotec issue, not a Pi issue. If you use one of those you’ll need a USB hub in the middle, or get the newer model Gen5+. A dongle like USB hub worked for me.

2 Likes

Please read the docs before asking.

Sorry Markus. I searched the docs for Raspi but did not see that question.
Didn’t think of reading the manual for that.

Never mind, WTF still RTFM nowadays.