White page after login as admin

Openhab works fine till I login as admin. Then I get a white page. The same happens after reconnecting to myopenhab, then I only get the white page.
Any idea what could be the reason?
In the frontail I found:
2021-03-18 10:27:46.103 [WARN ] [.io.rest.auth.internal.TokenResource] - Not refreshing token for session e97dedc1-5787-4cab-b515-0cd52912a976 of user Reini, missing or invalid session cookie
2021-03-18 10:27:46.114 [WARN ] [.io.rest.auth.internal.TokenResource] - Token issuing failed: invalid_grant
2021-03-18 10:27:46.318 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 12862408 failed: HTTP protocol violation: Authentication challenge without WWW-Authenticate header
2021-03-18 10:27:46.322 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: HTTP protocol violation: Authentication challenge without WWW-Authenticate header
2021-03-18 10:27:56.591 [WARN ] [io.openhabcloud.internal.CloudClient] - Unsupported request method HEAD

What could I do?

Hi Reinhard,
I sympathise because I’ve had all those cr*p error messages and glitchy behaviour for weeks now. Life is too short to waste time when systems behave erratically like this.
I’ve given up on the OpenHAB cloud host service and have simply set up my own remote access method using port forwarding. Port 8443 is used by openHAB for https access but DON’T open that one (because it’s known). Choose another totally different port number and you can cofigure your router to forward your chosen one on to 8443. The purists will be concerned about security but risk is low, no worse than any ports being open and a hacker would have to get through your openHAB login credentials too. Also, you can config your router to not respond to any external pings. I’m pretty sure the hacking world are more interested in banks and corporations than domestic home automation folk :rofl: My new setup is FAST, STABLE and reliable, no more gibberish messages in the log.
Good luck,

hi Denis, would you explain to me how to get free from the myopenhab cloud and access via the router?
until 2 months that I’m going crazy.
thank you

Hi Daniel,
I’ve pretty much described what to do in my reply to Reinhard. You just need to read up/study/look at youtube videos on how to do PORT FORWARDING on routers but particularly on YOUR router. Choose a port number up in the 9000’s or 10000’s, doesn’t matter what. Just DON’T choose port 8443 to expose externally. You will need a STATIC PUBLIC IP address (virtually impossible to get now) or else use a dynamic Public IP address service (DDNS). As an example, you would be logging in to your OH system from an EXTERNAL network (remote access) using a browser by typing something like ‘https://YOUR_PUBLIC_IP:9783’ if you had chosen to open port 9783. Note the colon after the IP address and that it’s https and NOT just http. When you login, you should get the usual username & pw screen. You can test if everything is working by turning OFF wifi on your phone so that you’re not ‘in’ the local network and using the phone CELLULAR service only which puts you ‘outside’ your local network.

thank you very much Denis
the static public ip i have it, when i access remotely with https: // mypublicip: xxxx, i can access openhab right? or to the router?
I do this because I can no longer unlock the admin in myopenhab.org

You’re welcome Daniele,
You’re very lucky to have a static public IP, very hard to get these days :+1:
When you type in your publicIP:xxxx you get the usual normal login screen of OpenHab asking for your username and password. The port forwarding mechanism will have brought you straight to the actual OH server running on your PC/Mac/RPi or whatever you run things on. I run openhab from a folder on the Desktop of my Macmini which also runs my media/movies and my security cams in the house. Anyway you won’t have to interact with or see the router login itself.
I’d say forget about the ‘openhab.org’ thing. That cloud access service became a pain and I abandoned it. To be honest, they would be better asking people to subscribe/pay for a stable/reliable cloud system.
I have a stable reliable fast remote access system since I did my own thing with opening ports. Ignore the scaremongers about hacking into your system…who on earth would be interested…? :crazy_face:

very good good, thanks for the help.
therefore I am able to access openhab and the administrator does not make me more problems.
did I get it right?

I don‘t like to repeat myself, but you force me to do so.
As written in many posts before, the openHAB foundation can not provide a paid service for being a non profit organisation. Furthermore, we don‘t have the manpower to guarantee any SLA.

I have just checked the connection to my openHAB 3.1(stable) server on my iPad via mobile network and myopenHAB. Everything is working fine, even admin login is working and I can change settings.

IMHO, you should enable trace log level for your cloud connector bundle to let us see, what‘s going wrong.

Hi Hans,
Yes I appreciate the position of it being non-profit, but maybe there could be a way for members to ‘donate’ on a ‘voluntary’ basis towards the maintenance and people’s time and effort. It could have a charity status to allow that. I get that there are a core group being very generous with their time and thus one feels bad about complaining about things and thus a ‘contribution’ would go towards rewarding the core group. I think many of us would like to show our appreciation that way.
Hans it may be that the cloud service is fine at the moment but I (and others) were having issues and I do have limited patience for having to keep tinkering/digging into a system to fix it or to request help. Thus I decided to opt out and implement a simple robust (with faster response) solution which worked better for me and is still fine.

Hi Daniele,
Yes that’s it exactly. You’ll have a clean remote login directly to your OH.
I should say that there’s nothing wrong with Cloud services per se and many home automation insist you operate that way. For example, I have Vera Plus hub running a simple system in another property and I use the Vera Cloud service (free also) to remote access login. It very occasionally throws a wobbly but mainly stable and fine.

It is not that easy. Since starting the foundation, there is an option to donate money, and this is highly used. Thanks to all donators here. This money and part of the membership fees are used to pay the infrastructure used for openHAB (website, build servers, myopenHAB cluster, etc.) But we cannot hire staff to run the cloud service. Actually, it is just 3 guys taking care of development and maintenance. So please understand that it takes time to solve reported issues.

In general, myopenHAB runs really stable, so to find the root cause for issues people report, we definitely need logfiles to analyse. And it is not much effort to provide those.

If you are happy with your solution, than go for it. But don‘t complain if you got hacked. We already had such reports in the past.
You‘d better think of a VPN solution to connect to openHAB from outside your network.

1 Like

Hi Hans,
Thanks for your reply. I didn’t realise I could donate, thanks for the info, so I’ve just sent a few bob to the foundation now :+1:
Yes absolutely I appreciate the core staff is small and of course it would take time to get around to everything, so no complaints there.
I do have a paid VPN service actually so I might take your advice about using it for remote access to OH. Regards,

1 Like

right you’re right, could you tell me why I can’t unlock the administrator anymore? the credentials are correct, I also re-registered with a new uidd but nothing.
I see the home but the administrator does not unlock, he keeps asking me for my credentials

Could you please post a screenshot of whats happening and a log extract from that time.

from smartphone how can i see the log?

He kepps asking me a credentials

Do you have any special characters used for the admin user and/or password?

the credentials are the same,
username = my email
pwd = Xxxx_1234