Why is openHAB so difficult to setup and use?

Windows 7
HP proliant server (SSD + 4 x 2TB hot swappable HDD’s) 16gb ram

I’m a security integration engineer by trade, Cctv, alarms, access control, media systems, Wi-Fi networks etc
I’ve succesfully home automated various things like LED strip lighting around the house using wires and relays via my NVR and alarm panel.
I’m now wanting to move in to voice control via Alexa and maybe Siri and/or Openhab iOS app.
I’m not wanting multiple devices connecting to random servers all over the world, which has brought me to openhab.

I’ve already purchased Sonoff wireless relays and ‘hacked’ to install Tasmota firmware.

I’ve read lots of tutorials and literature from here and many different blogs to try to get this set up. I had a few issues firstly with getting openhab to run on my server, then MQTT broker loading, to the point were I’ve uninstalled everything with the aim of starting fresh.

I think a java problem has been the main issue as my broker would not load at all no matter what version of Java I tried, or could that be windows? Running as admin makes no difference.

I must say I’m far from a programmer/coder but I’m tech savvy and as aforementioned, I’m old school hands on the tools type of engineer. I want to learn more about coding and did initially think this would be a good start but it’s already consumed a massive amount of time and I feel I’m no further forward.

Is openhab really that difficult to install on windows, have a MQTT broker, a couple of magic home Wi-Fi led controllers and sonoff relays to control via Alexa/openhab app set up?

Help with any of the above will be much appreciated and in return if anyone needs any physical connection advice I’ll be sure to help!

Cheers, J

It could be a java issue, but not knowing what java version your server is running, nobody could really tell.
If your server is powerfull enough, why not setup a VM an run openHAB2 there ?

Without more details like what specific broker are you trying to install and use before we can comment on your issues, in addition to what Java version you are using and such.

I can say that Windows is fully supported but the vast majority of OH users run it on Linux. I would say a majority of those run on a Raspberry Pi or similar board computer with those running in VMs not far behind. And of those who are running Windows, the majority are running on Win 10.

So, your overall setup is not all that common among users on this forum. It should work and work well but we don’t have enough information to help.

I can say though that the most hassle free way to get OH up and running with an MQTT Broker would be to get a RPi or create a VM like hmerk suggested, install a Debian based Linux (server edition) and use the openHABian scripts to configure the OS and install all the servers for you. While openHABian is geared towards RPi users, it can be used on any Debian based Linux.

I agree. Unless you have a compelling reason to use something else, I think openHABian on a Pi is the way to go. I personally like to reserve my free time improving my openHAB installation itself, not fiddling with Linux. Plus, Raspberry Pis are so inexpensive that you really can’t go wrong.

1 Like

Thanks for the replies. Sorry for not including more information regarding Java version etc.

Broker = Mosquitto
Java = I tried multiple options, 8, 9 etc

I actually have a Pi that isn’t currently set up, I could have this up and running later today but just because I already have a mini server running I thought that might be an easier place to run OH. The VM sounds like a good option.

Rather than go against the grain and have too many issues, I’ll attempt the VM option first, if that proves too tricky for whatever reason, I’ll then fire up the Pi I have spare.

1 Like

You can still use the openHABian scripts in a VM. That would be my recommendation.

1 Like

VM setup, will be back to it tomorrow. Thanks.

I have had a version of openhab running on a mac mini since 1.8 - I have never had to do anymore more than unzip it and start it up to get it going. On Ubuntu - once Oracle java is installed it has been the same experience.


openHABian scripts? Could you point me in the direction of this?


Read the whole thing but you will want to follow the “Manual Setup” instructions in particular.