Wifi Led Tasmota flash and configuration

A week ago i had a problem, i couldnt change color of this controller with the binding wifiled

Then i tried flash with tasmota, and i solved the problem.
This controller allows control more than 5 meters of led strip.

This is a tutorial for the people that have the same problem

First prepare the device for upload tasmota

Then flash the device with tasmota: Important, you have to press the button of the wifi controller for entrer in flash mode

When the device finish to flash, you must enter in the http of tasmota and config the device with the custom pins

Configuration -> Configure Module

Module type: 18 Generic

And in console you have to enable PWM functions within tasmota. To set PWM mode just type: SetOption15 1
Once you finish to config the wifi controller, config openhab items, rules and sitemaps


Color  ColorMagicLed "Color Salon" [ "Lighting" ]

String LedsMagic "Leds Color [%s]" {mqtt="<[broker:tele/MagicHome/RESULT:state:JSONPATH($.Color)]"}

Switch LedsMagic_power "Leds Salon [%s]" [ "Switchable" ] {mqtt=">[broker:cmnd/MagicHome/POWER:command:*:default], <[broker:tele/MagicHome/STATE:state:JSONPATH($.POWER)"}

Dimmer Dimmer_Salon "Dimmer Leds Salon [%.0f %%]" {mqtt=">[broker:cmnd/MagicHome/DIMMER:command:*:default], <[broker:tele/MagicHome/RESULT:state:JSONPATH($.Dimmer)"}


rule "Leds Salon"
    Item ColorMagicLed changed
    var HSBType hsb = ColorMagicLed.state as HSBType
    var Color color = Color::getHSBColor(hsb.hue.floatValue / 360, hsb.saturation.floatValue / 100, hsb.brightness.floatValue / 100)
    var String rgb = String::format("%1$02x%2$02x%3$02x", color.red, color.green, color.blue )
    publish("broker", "cmnd/MagicHome/color", rgb)


Switch item=LedsMagic_power
Slider item=Dimmer_Salon
Colorpicker item=ColorMagicLed

1 Like

The trigger of your rule is ColourMagicLed but you have posted the item definition for it.

Fixed, Thank you

Tasmota supports HSB since a while. No need anymore for a conversion rule HSB to RGB

Hi, i will update firmware tasmota today. My wifi controller is the same off this picture. Could you explain more about button wifi we need too press to flash? Is the same wi-fi button to reset configure behind the module beside the green and red mini lights? Is the only button we can push correct?
tks a lot

Hi @vinicius_chaves
Yon will be better off asking this question in a dedicated tasmota forum:


Have you figured this out @vinicius_chaves ? I’m trying to flash my controller and am having problems getting it into flash mode. Maybe @david7312 can chime in on clarification? :slight_smile:

To get into flashmode GPIO 0 hast to be pulled down to GND before any connection is made.
If the reset button is connected to GND anf GPIO 0 then you have to press and hold until
you made the connections. Easiest way is to power it via the USB - Serial Adapter (3.3 Volt!!)
So you just Press the Reset Button and plug the adapter in USB Port.
Dont use for flashing FTDI Adapters! The doesnt deliver enough current on the 3.3 V rail.
Use a CH340 adapter instead.

Good Luck

Thank you very much for the clarification!
I just ordered a CH340 so when it comes in later this week i’ll give it a shot :slight_smile:

@Johann_Obermeier would the GPIO 0 pin be the one that says “IO” in the picture at the top?

I think yes. Since i dont own this device i cant gurantee