Wifi network interface wlan0 problem

Hello, I have a problem with wifi connection on Raspberry Pi 3 with openhabian. At my home network I use home SSID, password and WPA2-Personal encryption. And and RPi is connected to home network without problems.

Now I moved RPi to another physical location where I use same wifi network configuration as at home (same SSID, password and encryption) but RPi won’t connect to wifi network, but it works over ethernet interface.
My wifi config files are:

/etc/dhcpcd.conf:

# Example static IP configuration:
interface eth0
static ip_address=192.168.0.23/24
#static ip6_address=fd51:42f8:caae:d92e::ff/64
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

interface wlan0
static ip_address=192.168.0.24/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

# It is possible to fall back to a static IP if DHCP fails:
# define static profile
#profile static_eth0
#static ip_address=192.168.0.23/24
#static routers=192.168.0.1
#static domain_name_servers=192.168.0.1

# fallback to static profile on eth0
#interface eth0
#fallback static_eth0

/etc/wpa_supplicant/wpa_supplicant.conf:

# config generated by openHABian wifi function
country=SI
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
        ssid="K1"
        psk="12345678"
        key_mgmt=WPA-PSK
}

/etc/network/interfaces:

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp

Can anybody, please, give me some suggestion about solving this ?

Peter

:slight_smile: google it… there are so many resources online on how to configure the wpa_supplicant.conf

one example: https://weworkweplay.com/play/automatically-connect-a-raspberry-pi-to-a-wifi-network/

Angelos, believe me, I’ve googled a lot before I wrote my post :wink: And in my home network there is no problem with wifi. But on other router with same SSID, password and security type it doesnt work … I checked the link you send but unfortunately, it doesnt help …

Is the wifi signal strong enough for the PI in that location?
The PI need a good signal, its antenna is not that good

Yes it is, I have no problem connecting notebook or mobile phone to wifi …

Hello, I found that wifi signal was really to week for RPi. I moved it to another location and now it works.

Hi - may I bring up this topic again cause my problem couldn’t be described better?
I installed the latest stable openhabian-image (and had some other problems with homegear…) but from the moment I enable WLAN (using ‘openhabian-setup.sh’ with “WiFi setup”) I got network problems.

  1. I enabled WiFi support (see above) with SSID, Key - rebooted and could not access my Raspi4.
  2. The disabled WiFi-Support from the console and rebooted - no difference
  3. I edited the network configuration files with static IP addresses (based on the examples of this thread) - and rebooted
  4. I could access my raspi from a PC, both IPs worked fine (could work with openhab :slight_smile:)
  5. then I disconnected the LAN-Cable - wanted to work via WiFi only - no connection anymore :frowning:; internet connection from the raspi console worked fine
  6. I rebooted - no difference from the PC side; openhabian still could use the network
  7. I reconnected the LAN-Cable - and everthing worked fine again :thinking:

Can anybody please give me a hint? Where can I find something more and detailled about network configuration (I know little about linux…)?
Thanks so much!

Hi all, I do have a similar problem. I setup openhabian having it connected through LAN cable. It all works fine.
But then I tried to enable WiFi connection using the config tool, entering the SSID, PW, Country code.
In theory all went well, I got the confirmation message and was asked to reboot.

But if I now remove the LAN cable and reboot, it will not connect to the WiFi. If I plug the LAN cable back, all works fine again.

It is not a signal strength problem, so far the RPi4 and the Router are next to each other on my desk.
Any help would be appreciated.

Thanks a lot