Windows: Eclipse SmartHome Designer does not open config from Samba share

I don’t think it is a bug at all: I never had to use drive mapping letters to get the Smarthome Designer (0.8) to work:

the bug only apeares if the conf folder is on the top of the share, like in the openhabian default config

Good evening,
I still have problems to get this: I have a fully working openhabianpi (on Raspberry Pi) with working samba-share:

I set up today a brand new WIN10 PC and try to get the files in my local ESHD. either by network - url or by typing ‘Z:’.

But obviously no correct results:

What I’m still doing wrong? Any help kindly appreceated!

I’m on Windows 8 but in Designer I just click computer, click on the mapped drive to highlight it and then click on the open file icon to the right of “configurations”.

So- I still have the same issue. But I think, I might found a working solution for me. Due to @cirf information about problems with binding top share in samba I just added a further samba share for the ‘etc’-folder in my pi configuration:

So by selecting now the sub folder ‘openhab2’

I now can work with the ESHD:

I’m wondering why this work around is not mentioned somewhere else…
Again, many thanks to all advises, warm regards, Dirk

1 Like

I think that’s because if users start to share their /etc without knowing exactly what they’re doing it might be a big security problem for them. A lot of files important to the system there…

I agree - but this workaround has nothing to do with ‘hassle free’ installation. And as mentioned: my hassle free openhabian installation didn’t support samba share for the proposed ESHD (Eclipse SmartHomeDesigner). Any how - it now works for me.

for some reason if you run eclipse smarthome designer as administrator the mapped drive / share won’t work.

running it normally works fine.


Hey, I only became aware of this thread just now. @dikahab I’m not sure what was the original problem as the openHAB2-conf share was always okay for the Designer on my system and others.

I just wanted to mention that openHABian nowadays offers one single share for all interesting folders, it’s called “openHAB-share”. Whoever had problems with Samba and the Designer (on openHABian) in the past should check out this new share.

@mohsh86 I don’t know why you would even do that but that sounds logical to me. If you mount a share as “user1”, other user accounts (including administrator) will not see it.

I had the same problem, but directly on my Ubuntu 16.04 server, no Samba/Windows sharing needed.

I would point Designer .8 to /etc/openhab2 and it would complain and only load my Items. The error was:

16:01:27.264 [main] WARN  o.e.s.d.u.i.v.ViewContentProvider - Error getting children for folder 'config'
org.eclipse.core.internal.resources.ResourceException: Resource '/config/config' does not exist.

My workaround:

    cd /etc/openhab2
    ln -s . conf

Then I pointed Designer at /etc/openhab2/conf instead.

Yep, a symbolic link named “conf” pointing back at the current directory. A circular link. Ugh.

But it worked!

Well, it works until you exit Designer and try to start it anew. Then it just dies on startup.

To make it work again, I had to remove ~/.eclipse (recursively) and do it again. This time I got a bit smarter:

cd ~
mkdir -p openhab2
cd openhab2
ln -s /etc/openhab2 conf

Then in Designer, I pointed it at ~/openhab2/conf so that it would have the folder “conf” as part of the name that it so badly wants.

Success, even upon exiting and restarting Designer.

Moral of the story: Designer wants everything to be in a folder named “conf” or it chokes.

Thanks, tried that but to no avail. Keep getting the “resource /config not open” error.
i think I leave eclipse for what it is

I second the error “resource /config not open”

Confusing b/c this app is purpose built to work with OpenHAB files/folders yet I get this error anywhere I try to use in Designer. Also, there is no folder called config…

I’m willing to bet the difficulty in coding some logic into the App like,
“User selected a folder. Where am I? OK, I recognize this, now I know where the folders I want are” is trivial. :frowning:

Hello everyone,

in conclusion this thread seems like a mixture of different problems in relation with Samba shares and the Eclipse SmartHome Designer.

I can confirm, that the setup instructions in this documentation article were and still are correct. If you have issues of any kind, please check your setup once again. Your Linux host needs to provide a share for /etc/openhab2. The share needs to be mounted to a drive letter on your Windows machine:

If you are working with the openHABian system, your system provides one Samba share called “openHAB-share”. First mount the share to a drive letter, then open the subfolder “openhab2-conf” in the Eclipse SmartHome Designer.

If you are experiencing problems related to the Samba file sharing, expect them to be unrelated to the above and please create a new thread!

Happy Hacking :fireworks: