WoL + LG Webos TV not working


I’ve been going at this for a couple of days now. I can turn my TV off, change channel etc.

My TV supports WoL, and I have enabled it.

Eventually I “gave up”, and decided to use the example code provided here: https://www.openhab.org/addons/bindings/lgwebos/

Once again, everything except turn on (wol) is working. Ive triple checked the mac address and IP for my TV.

Running openhab2 on Ubuntu 19.10. TV is on WiFi.

My TV model: LG 65UJ750V

Logs says wake on lan packet has been sent.

Greatly appreciate any help. Ive tried to include necessary information (os, tv model, code etc) - but please ask for more if needed.

Best regards,

Did you try to send a magic packet without using openHAB?

Just to make sure WoL is working in general?

This is my first WoL attempt ever. I’ll google and find out how to send a package from terminal :slight_smile: will report back

Ok so this is interesting. I downloaded a piece of software to my Windows PC to wake up devices through WoL.

It didnt turn on my TV. But when I changed a setting saying “Send multiple wake-on-lan Packets” from 1 to 5… it turned on the TV. So it seems my LG TV needs multiple WoL-packets to start.

Any ideas how I can send multiple in openhab? Tried making a rule that just sent five individual wol commands to the TV, but didnt work:
Switch LG_TV0_WOL { wol=“”,wol=“”, wol=“”, wol=“”, wol=“” }

Help? :smiley:

** UPDATE **
I tried through command line windows with wolcmd application. Worked sending only one… wolcmd b4e62ad184XX

COULD the problem be me running ubuntu/openhab through a virtualbox?

Perhaps same Problem as in this Thread?

LG TV not paired to openHab? :wink:

Its paired, and has the same ID. Unfortunately!

your wol item is wrong. The ip address part should be a broadcast address
Try this - note it’s .255 (broadcast address) not .158 (i.e. do not use your specific tv ip)


Oh my god. I’ve read so much documentation and threads, but forgot to read the //comments in the example code. A little bit embarassed now. Thank you Jim :slightly_smiling_face:

Needless to say - it worked!

i’d like to refresh this situation

{ wol="" }
{ wol="" }

isn’t powering TV on

Log says

[nhab.binding.wol.internal.WolBinding] - Wake-on-LAN packet sent [broadcastIp=LGwebOSTV.fritz.box, macaddress=785dc87ce034]


[nhab.binding.wol.internal.WolBinding] - Wake-on-LAN packet sent [broadcastIp=, macaddress=785dc87ce034]

what am i doing wrong?

send WOL command from Windows PC works.

Nevermind. Found the problem.
In my case its

{ wol="" }

i forgot i changed the subnet :man_facepalming: