[Workaround] Problem: Wifi LED Binding - Things protocol state switch to default after reboot

I have a problem with the WiFi LED Binding, when I reboot or restart openHAB.
Online Things protocol switch to default protocol LD 382A at reboot.

Things that are unreachable or offline remain on protocol LD686.

I use the following LED controller:

Sunix® RGB / RGBWWCW Kontroller 12-24V Mini Wireless WiFi

There is no information in the logfiles.

I use openHAB 2.2.0 Build #1068

Does anyone have the same problem?
How did you solve it?


I’m having trouble with this controler too.

I can’t change the brightness or color, only “ON/OFF” works for me. Tried multiple configurations…

I will look if I can observe your problems too.

WOW thanks.

If you need further information, please let me know.

I have the same problem as @The-Elk with that gear. After restarting the openhab the “Device protocol” setting is back to default. No storing of the manual change of the device protocol in in openhab.
I my case, when I switch OFF the device with the LD382A protocol setting the WW switches permanent ON (100 %) and the only way switch it OFF again, is the use native app (Magic Home).
I have two of those and one is in the sleeping room and it is really annoying when I have forgotten to change it again after restarting openhab…

Regarding @SpaceGlider’s problem, I had it too. With that native App device type setting:

and the LD686 Device Protocol (I’ve also as Device Driver used “FADING”) setting all functions are accesable to me.

had anybody find a solution for the problem?

I found for me a workaround. After any reboot the right configuration is working.

I defined manual a things file: wifiled.things

Thing	wifiled:wifiled:F0FE6B19CB2A	"NAME" 	@ 	"LOCATION"	[ ip="",	 port=5577,	 pollingPeriod=3000,	 protocol="LD686",	 driver="CLASSIC",	 fadeDurationInMs=1000,	 fadeSteps=100 ]

These files are stored in the things folder under the openHAB configuration path, e.g. /etc/openhab2/things/ or openhab2/conf/things.

for more information:


With the Device driver set as FADING, program and program speed functions are not accessible according to the binding documentation.

Do you concur that this is the case?

Has anyone managed to get these functions working with these LED controllers and if so, what did you do?


With the FADING program I use the default values for program speed. It works to me - the light is fading. I’ve not tried to change the values, so I cannot tell if they are accessible from a functional perspective. In the GUI it seems to be changeable.

Thank you for the reply.

I meant the program such as blue-strobe, red-green change etc.