Wrong IP-address after reboot in openHAB Hue Emulation

Hi all,
after reboot i allways have a wrong configuration IP-Address of the hue-box in the emulation config map under paperui
it is allways the ip of the openhab box and not the ip address from the hue box.
so i have to change manuly the address after every boot to get the emulation working

my question: where can i set the ip-address of openHAB Hue Emulation in a config file

many thank for all replies


Not sure exactly what you mean.
The Hue emulation emulates a Hue bridge (read pretends to be one), which means it makes openhab items look like lights from a hue bridge (if tagged correctly). Hence, the IP number after restart (your computer is the emulated Hue box), the config choice is only given in the case you have more than IP number associated with this computer (more than one network interface).

If you want to control a hue bridge from OH, you will need to use the Philipps Hue binding, where you will need the IP number of the real Hue bridge to define your thing.

You don’t specify the OH version you are using, the above applies to OH2 (don;t remember how it worked for older versions)


so i tryto clearify what i mean.

my OH box (running 2.3) has the IP 192.xxx.xxx.30

my Hue bridge use IP 192.xxx.xxx.9

so duriing first discovery of the openHAB Hue Emulation it came up as offline. Looking donw to “Configuration > Things >Edit > openHAB Hue Emulation” in paperui i found the IP of OH2 (192.xxx.xxx.30)

now i correct the IP in this paperui tav to the correct IP 192.xxx.xxx.9

use the check button.

and than everything is fine. the openHAB Hue Emulation comes online and everything is fine

after a reboot the openHAB Hue Emulation comes up offline. Looking to the settings: “Configuration > Things >Edit > openHAB Hue Emulation” shows that there is again the IP of OH2 (xxx.xxx.xxx.30)

so i have to correct it again to get the system working.

Is this understandeable?

My question is yet: where else can i set the IP adress of the hue bridge (xxx.xxx.xxx.9) so that after a reboot this information is persistent?

Changing with paperui is not persistent.


Mit freundlichen Grüßen - With kind regards - cul8ter - ciao - salut

Stefan Heinz

D-55413 Weiler b. Bingen


Fon 0049 (0) 6721 992653

Hinweis: Der Inhalt dieser eMail ist vertraulich und ausschließlich für den bezeichneten Adressaten bestimmt. Wenn Sie nicht der vorgesehene Adressat dieser eMail sein sollten, setzen Sie sich bitte mit dem Absender der eMail oder unter der angegebenen Telefonnummer in Verbindung und vernichten Sie diese eMail auf Ihren Speichermedien.

Notice: The information contained in this email is confidential. It is intended solely for the addressee named above. If you are not the intended recipient, please notify the sender immediately and destroy this message on any media of yours.

Now, maybe someone can weigh in, but I still do not understand what is going on and it can be my fault of course; let me explain where I think you went wrong and why:

Just for clarity:

  • A hue bridge is a piece of hardware (with software) that allows you to control hue lights through your app, through alexa or through OH or other; meaning you need it to talk to your hue lights

  • Hue emulation is a software program that creates a virtual hue bridge on the computer that runs OH2; its purpose is to act like a hue bridge for items in OH2 (any light, switch, dimmer, roller shutter, ect)

  • the hue emulation makes a virtual hue box it makes your OH2 pretend to be a hue bridge

  • just for clarity if you want to control lights in OH2 use this: https://www.openhab.org/addons/bindings/hue/

  • An IP number is a unique number for devices on your LAN and can be used only by a single device.

  • Your Hue bridge has an IP number, AND your hue emulation can be reached through an IP number as well (this IP number is connected ot the computer that runs OH, in most cases, this is only one IP number and you will not need to adjust anything)

If you assign the same IP number to two devices on your LAN you will create a conflict that essentially renders both devices unreachable. In your case, I would venture to guess that your hue emulation actually is not doing anything as you are attempting to give it an IP number to which it does not have access (it is already owned by the bridge and the hue emulation cannot take it away).

I am having both on my LAN: a hue bridge and OH2 running the hue emulation; both have different IP numbers and as I have only one IP number for the computer of my OH, I am using the default value.

Have a look at the docs again, maybe this helps:

It says in there: (Optional) For systems with multiple IP addresses the IP to use for UPNP may be specified, otherwise the first non loopback address will be used.

Systems in this case means, the computer that runs OH2. If you run OH on a RPI a standard laptop or desktop; the overwhelming odds are you are having only one network interface (and therefore only one IP number) on your computer running OH2 and this option is irrelevant to your setup.

Now you may have another issue on your system that prevents you from achieving what you want, but you will need to put forward more error logs and other info with regard as to on what system you are running OH2 and your use case (for what purpose do you want to use the hue emulation; what are you hoping you can automate).

Sorry Man,

i don’t wantcto read …

As i said: i have a working environment with a hue bridge and a hue emulation!!!

So i am able to config the system in the right matter!

The problem is that after a reboot of the openhab box the manual set of the IP in the hue emulation settings is gone!

Wuestion is: is there an other location, jar-file?, anything instead of paperui to config the IP-address of the hue bridge in the hue emulation

Gruß Stefan Heinz
Send mobile

Dear Markus,

nice to be informed about everything i allready knew!!!


Because i has written, hhat i have a fully wirking environment!

Please read caregully, what is posted!

Gruß Stefan Heinz
Send mobile

Sorry out of my depth here…don’t even know why you want to do what want to do… as I tried to explain It does not make sense at least not how I understand the hue emulation and the hue binding…but as I said maybe I am misunderstanding something here.

I am running the same configuration and I am not assigning the ip for the bridge to the hue emulation. I just leave the ip of my oh system.

Hopefully some one else can shed more light on this.


I am having exactly the same problem. Did you ever get a solution to this issue? I know it is 2 years later.

Thanks in advance.

Hi Edward,
Very short answer: No.
But at the moment my system runs without thus problem. nobody kniws why ir how. But it works
cheers Stef

@sjheinz, @ParisEdward, what lipp_markus said was correct but I think there is misunderstanding here as your description of the issue doesn’t make sense. The openHAB Hue Emulation Service and the Philips Hue Binding are two different things (“system integration” and “binding” respectively) and are not connected in any way.

That is not possible as the Hue Emulation is not a Thing and does not show up on the Things page. Hue Emulation is under Configuration > Services > IO. Perhaps if you could post a screen shot of the IP setting you’re referring to?
The only IP setting for the Emulation Services is the “Optional Discovery Address” which is blank by default, and can be set to any of the openHAB host’s IP addresses (if you have multiple set up). You would never want to set this to the same IP address as another Hue Bridge otherwise you would have an IP address conflict.