WTRFID Mini Keypad RFID/Z-Wave

Tags: #<Tag:0x00007f434aa5c348>

If your device is the same as the one we already have, I just need to add the device type & id. We then wait for the next export to GitHub ( usually weekly) and then for the snapshot build to include the binding.

Then you can update your binding, delete the Thing in OH and re-discover, hopefully for profit!! :smiley:

owkay.
I am running openHab 2.4 stable version.
Do i get the updated binding?
Updating the binding is by uninstalling it and then reinstalling it?

There is a script that can just update the binding to the latest snapshot.

I have determined you ave a newer Z-Wave Plus version of the device we already have so I will create a new database entry for this.

EDIT: The new entry for this device is here, awaiting review.

1 Like

thank you for your effort.

Stupid question, but how do i get this in my openHAB? is that automatic?

The database is part of the binding. Assuming you do not want to upgrade to a snapshot build, there is a script that can update the zwave binding. You f=then need to delete & re-discover the Thing. It will reappear with the same thingid so any Items will not be broken.

I am running openHab on a Windows 10 machine.
Can i use the zzManualInstall.sh script?
In which programe do i run that? PUTTY?

Not for Windows 10 but, I suspect, the manual install instructions in the README file should work. @5iver wrote the script.

Installed GIT
During installation of GIT, add GIT Bash to windows context menu by selecting its option. After installation right click in your folder select GIT Bash Here (see attached pic) and use your sh command like for example:

sh test.sh

image

Found the answer here

and then run the script

bash zzManualInstall.sh

To bad, i get this
image

I have installed a fresh 2.5-snapshot
and i think i see the new device in the supported list

I have tried to add it but it is not recognized

2019-10-14 21:57:49.110 [ERROR] [mmandclass.ZWaveSecurityCommandClass] - NODE 9: Error decapsulating security message

java.security.InvalidKeyException: No installed provider supports this key: (null)

at javax.crypto.Cipher.chooseProvider(Cipher.java:892) ~[?:?]

at javax.crypto.Cipher.init(Cipher.java:1248) ~[?:?]

at javax.crypto.Cipher.init(Cipher.java:1185) ~[?:?]

at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveSecurityCommandClass.generateMAC(ZWaveSecurityCommandClass.java:517) ~[212:org.openhab.binding.zwave:2.5.0.201910141742]

at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveSecurityCommandClass.getSecurityMessageDecapsulation(ZWaveSecurityCommandClass.java:308) [212:org.openhab.binding.zwave:2.5.0.201910141742]

at org.openhab.binding.zwave.internal.protocol.ZWaveNode.processCommand(ZWaveNode.java:1238) [212:org.openhab.binding.zwave:2.5.0.201910141742]

at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager$ZWaveReceiveThread.run(ZWaveTransactionManager.java:498) [212:org.openhab.binding.zwave:2.5.0.201910141742]

You need to delete the Thing using the PaperUI and then discover again from the Inbox.

it is a fresh installation. There was nothing at the start

adding the BeNext Tag Reader 500

NODE 9: Device discovery could not resolve to a thingType! Manufacturer data not known

there is more information needed?

|zwave_class_basic|BASIC_TYPE_ROUTING_SLAVE|
|zwave_class_generic|GENERIC_TYPE_ENTRY_CONTROL|
|zwave_class_specific|SPECIFIC_TYPE_SECURE_KEYPAD|

@Bruce_Osborne Do you know what is wrong?

Yes. In order to identify the device OH needs 3 pieces of information from the device that are only obtained by full discovery. Here is a HABmin example from my system, shoring those numbers.

image

I have found something
I was typing benext_tagreader_00_000 instead i see in the doc it has to be benext_tagreader500_00_000
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1122?layout=openhab2new
I add the thing in a file

Bridge zwave:serial_zstick:controller “ZWave Controller” [ port=“COM3”, controller_softreset=“false”, controller_master=“true”, heal_enable=“true” ]
{
Thing benext_tagreader500_00_000 node9 “Keypad” [ zwave_class_basic=“BASIC_TYPE_ROUTING_SLAVE”, zwave_class_generic=“GENERIC_TYPE_ENTRY_CONTROL”, zwave_frequent=“false”, zwave_version=“1.4”, zwave_listening=“false”, zwave_deviceid=“512”, zwave_routing=“true”, zwave_beaming=“true”, zwave_class_specific=“SPECIFIC_TYPE_SECURE_KEYPAD”, node_id=9, zwave_manufacturer=“138”, zwave_devicetype=“7” ]
}

Now i am getting this
image

But it is still in REQUEST_NIF, what does that mean?

In HABMIN

OpenHAB has requested a Node Information Frame from the device and has not yet received all of the NIF.
I found this quote from the Zensys documentation on another forum.

When the Include Initiator in a node is activated it will issue a node information frame. This frame is part of the Z-Wave protocol, and specifies the capabilities of the node. These capabilities announced include the node type, whether the node is able to repeat frames, and other protocol relevant issues. The node information frame also contains the Home ID and the Node ID.
It is possible for the application to ask for the Node Information Frame from all nodes in the network and hence enabling any node to acquire information regarding any other nodes features in the network at any given time.

so i just sit and wait?

On some of my cheap Chinese battery powered motion sensors I have tried a few things.

Sometimes removing the battery for 10 seconds, reinserting it and waking up the device repeatedly worked.

Other times I have needed to attempt to exclude the device, factory reset it and include into the network again, repeatedly waking it up. You need to delete the old thing and may end up with a failed node on your network controller.

1 Like