WTRFID Mini Keypad RFID/Z-Wave

Yep. If you want to add this to the database then just export the XML for testing…

Oh dear - that might be a problem. If I understand the standard, it’s meant to be ASCII -:

Minimum code length is 4 and maximum 10 ASCII digits.

Hmm… I guess they try to bend the standard to get the RFID code into the keypad…
According to the manual they suggest that the controller, when presented with an unknown RFID token, searches for an empty UID and inserts the RFID code.

But that would only make sense if some kind of usercode-inclusion is activated by the user, otherwise anybody could register a new RFID token…

Is there any way to send the USER_CODE_SET command with payload to a specific node manually, maybe via Karaf?

1 Like

No - but the problem is not that simple. Since the standard is for ASCII - the binding is doing certain checks on the code.

I’ll check this with Sigma.

1 Like

Hi all,

I was able to get the notification_access_control channel up and running, Chris is helping me to add it to the database later today.

The alarm_access channel will be replaced by the notification_access_control channel. If you enter a correct code or place a registered RFID token in front of the keypad this channel gets updated: event “5” for “Away”, event “6” for “Home”. Afterwards you will be able to use this in a rule of some kind.

Home:

Away:

Concerning the registration of the RFID token: until we find a solution I had to cheat on openHAB and used FHEM for this process (I hope it’s ok to mention here)… but at least I have been successful, now I can use both the code and the RFID token to un-/lock the keypad!
If someone is interested in a small how-to I can post a walk-through here (or you have a look here if you want to figure it out yourself - it’s in German)

Regards, Christian

1 Like

I’m really interested. I just got the device yesterday and I’m really struggling how to add the RFID in OH2. Any help would be great. As I read the discussion I have to wait for a new definition for this device. Is that correct.

Yes, the database change is still waiting for approval.

OK, here’s what I did (on a CentOS 6 machine):

  • shut down openHAB2
  1. download the FHEM package: http://fhem.de/fhem.html#Download
  2. extract the archive
  3. run “make install”, FHEM will be installed in /opt/fhem
  4. before running FHEM I had to install some additional packages: perl-Device-SerialPort, perl-Crypt-Rijndael and usbutils
  5. start FHEM:
perl fhem.pl fhem.cfg
  1. click on “Everything”, there you should see your Zwave Controller “ZWDongle_0”, click on it
  2. at the bottom of the ZWDongle_0 page you should see the “nodeList” with all your Zwave nodes, named “UNKNOWN_1”, “UNKNOWN_2” and so on
  3. remove the back cover of your keypad
  4. at the top of the ZWDongle_0 page you can see two rows, one with a “set” button and one with a “get” button and some dropdowns. In the “set” row, choose “addNode” and “nwOn” and click the “set” button
  5. activate the inclusion mode of your keypad by holding the tamper lever for one second and then releasing it. FHEM writes some logfiles in /opt/fhem/log, there you should see an entry like
2017.01.05 10:21:37 3: ZWave got config for schlagelink/minikeypad.xml from ./FHEM/lib/openzwave_deviceconfig.xml.gz
  • wake up the keypad multiple times in order to initialize it in FHEM. The keypad creates it’s own logfile, so you can have a look what’s happening there (/opt/fhem/log/ZWave_ENTRY_CONTROL_29-2017.log in my case)
  1. now it’s getting interesting :slight_smile: press the “Home” or “Away” button on your keypad, wait for the LED to turn on, and put your RFID token in front of it. The log file should show something like
2017-01-04_19:07:48 ZWave_ENTRY_CONTROL_29 wakeup: notification
2017-01-04_19:08:37 ZWave_ENTRY_CONTROL_29 userCode: id 0 status 0 code 8fd7c20d412002800000
  • this is your RFID’s usercode, now you can store it on the keypad: go back to you browser, when you click on “Everything” you should see your keypad Zwave node, click on it to open the configuration page
  • again, you see a “set” and a “get” row. Choose “userCode” in the “set” row, and enter something like this in the textfield at the end:
5 1 8fd7c20d412002800000
  • where 5 is the usercode id, 1 is the status (activated) and the RFID’s usercode. Click on “set” to execute the command
  • now you can test it, you should see something like this in the log:
2017-01-04_19:09:31 ZWave_ENTRY_CONTROL_29 alarm: AccessControl: Keypad Unlock Operation, arg 0105
2017-01-04_19:09:32 ZWave_ENTRY_CONTROL_29 wakeup: notification
2017-01-04_19:09:39 ZWave_ENTRY_CONTROL_29 alarm: AccessControl: Keypad Lock Operation, arg 0105
2017-01-04_19:09:39 ZWave_ENTRY_CONTROL_29 wakeup: notification

That’s it, shut down FHEM, start openHAB2 again, and you’re done :slight_smile:

Regards, Christian

3 Likes

Thanks. It’s FHEM not supporting AddNode for my controller :frowning: . I think I have to wait for adding the correct usercodes is supported in OH2. Is it possible to enter just the numeric code for the keypad into OH2? I can live without the RFID for now.

O dear… yes, you can enter the digits via Habmin

Christian

The initial response from Sigma on this is -:

We are aware that some RFID tag readers have adopted this non-compliant approach which goes against the specification.

I’ve asked them if this means they are going to update the standard or if these devices are considered incompatible/non-standard devices… We’ll see - hopefully they plan to update the standard.

Is it a matter of filling the code 1234 in one of the usercode and wait for the new definition or is there more to it?

It’s not currently possible to set a binary code - fullstop. The binding doesn’t support this since the standard says it’s not allowed.

If you just want to set a normal user code like 1234, that’s no problem with the current binding.

As I said I have this device since yesterday and probably I’m a donkey. This is what I have done: I have set the usercode in HABMIN say 1234. I have created all the items I can. If I press Home or Away 1234 Enter I would expect some event to be triggered, but nothing is happening. So what am I doing wrong? Please help.

Nothing is happening yet, that will change as soon as the database every mentioned above has been changed. Then you can watch the status of the new channel and create a rule.
You can look at the zwave debug log if you want, with the current binding you can at least see that something is happening when you enter the code

That’s good news. Any idea when Chris will be ready?

I’ll update the database tonight.

1 Like

Perfect!

Hey Christian,

I also bought this device a few days ago and struggled with the openhab2 integration.
What a luck that there are other people with the same problem.

Thank you for your rfid-manual :+1:

I just tested it on a raspberry pi with raspbian 8.
It works how you described :heart_eyes:
For me, this workaround is ok.

And thanks to chris for this great support.
When chris updates the database and the new class works as you described it’s finally possible to use the keypad :blush:

Thanks to all involved!

Hi Chris,

The build didn’t went well tonight. Do I have to wait for the next successful build or is there a shortcut to enable the device a little quicker?

Thanks,

Casper

It’s only done manually unfortunately - I’ve just kicked off another build so lets see if it works this time (looks like it failed on some Karaf issues last night when I kicked it off…).