Xiaomi Aqara Gateway Developer Mode?

So I just picked up a Xiaomi Aqara Gateway yesterday with some temp and window sensors.
Installed everything fine in the Mi Home app, updated the firmware and added my sensors.

Everything is working great in its own eco-system and I am really impressed by it all, especially for the price.

Tonight I wanted to attempt to connect all of this to my OpenHAB RaspPi, however it appears that they have removed the ability to set the hub into developer mode based on the instructions on the bindings page and some quick Googling.

My question, has anyone figured out a way to enable this again or get this working with the Xiaomi Binding?

I don’t think there is a developer mode in Aqara Gateway.

@illxi It seems there used to be at one point but thats been temp removed. It is a supported device for the binding but it all hinges on getting it into developer mode.
Looks like tying this into OpenHAB currently is a no-go for the time being.

I am running temp/humidity and door sensors so its not a huge thing right now and the app works fine for the most part. Would be nice to get it all in one place though and then start tying things into the sensors.

In the app, go to the about page as described elsewhere, and tap in the blank area. Worked for me last week with the iOS app.

@peterloron Thanks for the reply. I went to the Firmware screen and tried tapping all over the place. No luck :frowning:
This is on the Android app and the Gateway running 1.6.0 firmware.

Same issue with the current XiamoiHome-iOS-App (V4.19.1)

When selecting the AqaraHUB, it looks like that:

When I click on the three dots in the upper right corner, I don’t get “about” - it will show immediately the “Settings”-page like this:

Any ideas?
Thanks

1 Like

Hey,
I stumbled over this when trying to figure out how to connect to the xiaomi v4 gateway.
Sounds quite straightforward to get the developer key, however I don’t have any Aqara hub/gateway to test on.
I’ll post it here if people want to try it out :slight_smile:

Specific operations for obtaining the gateway KEY are as follows:
1.Add Hubs on Aqara Home App, then login AIOT Opencloud Website and enter Console.
2.Select “Gateway LAN”, enter Aqara account and password.
3.Select the Hub to enable “LAN Communication Protocol” to get a random KEY.

I had no problem logging in to AIOT after registering in the app.

EDIT:
Found this as well. It’s a year old but might be worth a try.

The specific operation to obtain the gateway KEY is as follows:

  1. Open the Aqara APP and select the gateway device that needs LAN communication;

Note: Currently, only the “Upgraded Air Conditioning Companion” supports the LAN communication protocol function.

  1. By default, this page does not display “LAN Protocol”, you need to click “Device Type” 10 times in succession to display.
  2. Open “LAN Protocol”, get random KEY, and click “OK”.

Did anyone try this?
Did it work?
I’m considering buying an aqara gateway, but only if I can connect it to openhab.

I have one and I have no luck at all in getting into developer mode yet.

Really wish I could so I could tie this into my OH setup but so far no luck.
Mine all live on their own ecosystem and are somewhat useless to me until I can integrate my Xiaomi devices into OH.

Hmm, then maybe you should buy one of the Xiaomi v3 gateways so you can integrate your devices in, while its still possible to buy them.
In China Xiaomi has stopped selling the v3 in favor of the v4. But the v4 has no way for people to access developer mode just like the Aqara.

Have a look here https://github.com/koenkk/zigbee2mqtt

It requires a little tinkering but will allow you to discard the gateway altogether. I have just ordered the bits to try it out.