Xiaomi Aqara vibration sensor - text configuration

I just upgraded to openHAB 2.4 stable and with it came 2.4.0 of the Xiaomi Mi Smart Home Binding.

I’m using v2 of the Gateway (the one with the Radio, but without the Aqara-logo) and everything Comes online: Bridge, Gateway and the leak sensor. The Vibration sensor stays in Status: UNINITIALIZED - HANDLER_CONFIGURATION_PENDING


2018-12-17 15:16:33.788 [hingStatusInfoChangedEvent] - 'mihome:sensor_vibration:7c49xxx:158d0yyy' changed from UNINITIALIZED (HANDLER_CONFIGURATION_PENDING) to UNINITIALIZED
2018-12-17 15:16:33.781 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.dispose()' on 'org.openhab.binding.mihome.internal.handler.XiaomiSensorVibrationHandler@1191e6a': null
2018-12-17 15:16:33.794 [ERROR] [core.thing.internal.ThingManagerImpl] - Exception occurred while disposing handler of thing 'mihome:sensor_vibration:7c49xxx:158d0yyy': null
2018-12-17 15:16:33.813 [hingStatusInfoChangedEvent] - 'mihome:sensor_vibration:7c49xxx:158d0yyy' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-12-17 15:18:23.731 [hingStatusInfoChangedEvent] - 'mihome:bridge:7c49xxx' changed from INITIALIZING to ONLINE
2018-12-17 15:18:22.742 [hingStatusInfoChangedEvent] - 'mihome:sensor_vibration:7c49xxx:158d0yyy' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to UNINITIALIZED (BRIDGE_UNINITIALIZED)
2018-12-17 15:18:23.751 [hingStatusInfoChangedEvent] - 'mihome:sensor_vibration:7c49xxx:158d0yyy' changed from UNINITIALIZED (BRIDGE_UNINITIALIZED) to UNINITIALIZED (HANDLER_CONFIGURATION_PENDING)

My configuration:

Bridge mihome:bridge:7c49xxx "Xiaomi Gateway PL12" @ "PL12" [ serialNumber="7c49xxx", ipAddress="192.168.xx.yy", port=9898, key="123", pollingInterval=1000 ] 
		gateway			7c49xxx		"Xiaomi Mi Smart Home Gateway PL12" 	@ "PL12"		[itemId="7c49xxx"]
		sensor_wleak_aq1	158d0yyy	"Xiaomi Water Leak Sensor Holzofen"	@ "PL12 KG"		[itemId="158d0yyy"]
		sensor_vibration	158d0zzz	"Xiaomi Vibration Sensor WoZi West"	@ "PL12 WoZi"		[itemID="158d0zzz"]

did I miss something in my config?

found the problem? I have the same problem

no. Perhaps it’s a bug, because adding the sensor via PaperUI works. But I want to configure my System via config-files and not via PaperUI (config files can be backupped and restored and stuff).

I also have this problem with the Xiaomi Aqara Cube, known as sensor_cube in the binding. I has the same error in the log file you’re getting when added in a .things, but works fine when added through PaperUI.

I have the same error currently for the xiaomi door sensors, any fix yet?