Xiaomi Bindings Loose connection and Item not updated/triggered

HI,
I am setting up new installation with OpenHab 3.3.0 on Docker. Container have --net=host option, so all port are exposed to network.

I just have a 2.4 installation with all Xiaomi devices working fine since 4 years.
To testing with 3.3.0 I disabled Binding on 2.4.0 and enabled binding on 3.3.0.

Binding go ONLINE for sometime, then it goes offline, and only method to get it back online is to disable and enable the binding.

When Binding is Online, I can scan devices and it found it, I can devices as things, but I added a Switch and it does not trigger the action, but I can read battery level so it ssems that Binding work bu I cannot understan why it goes offline and why do not trigger switch actions.

Any help would be appreciated.

Marco

Tried also on a Classid Debian Box with OH 3.3.0 but same result, after some time Xiaomi Bridge goes offline. On OH 2.5.0 still working fine.

Marco

In case someone fall into this, issue is tracked here:

to fix you have to go to Code section of your bridge and manually add serial number:

UID: mihome:bridge:XXXXXXXXXXX
label: Xiaomi Mi Smart Home Bridge
thingTypeUID: mihome:bridge
configuration:
  ipAddress: 192.168.X.XXX
  serialNumber: XXXXXXXXXXX
  port: 9898
  key: XXXXXXXXXXXXXXXX

serianNumber is the line you have to add

Thanks for linking the Github issue tracker. I hope it will get some traction soon.