Xiaomi bridge staying Offline

  • Platform information:
    • Hardware: raspberry pi 3, Xiaomi Mi lumi-gateway-v3
    • OS: Windows 10 Pro x64
    • Java Runtime Environment: oracle Java Vesion 8 Update 201
    • openHAB version: openHAB 2.4.0-1 (Release Build)
  • Issue of the topic: Xiaomi bridge staying Offline.
  • Please post configurations (if applicable): Installed the Xiaomi Smart Home Binding and managed to connect the device with the Xiaomi App and get the token and developer key. Since nothing apeard in my inbox i installed the bridge and gateway manually.
    My problem is that when i auto search for it in OH nothing is found.![1|690x256]

    This is from the log of OH:
    2019-07-14 10:23:25.471 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing ‘miio:unsupported:04FF6428’ takes more than 5000ms.

2019-07-14 10:23:25.489 [hingStatusInfoChangedEvent] - ‘miio:unsupported:04FF6428’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2019-07-14 12:47:35.627 [hingStatusInfoChangedEvent] - ‘mihome:bridge:26c1fb9f’ changed from INITIALIZING to OFFLINE

I’m an OpenHab2 rookie so forgive me if im asking a dumb question. I followed this guide https://www.openhab.org/addons/bindings/mihome/
but came short when i had to autofind it in OH.

Tanks for the help in advance!

Anyone ?

Hi @angelstoev
The first thing I’ve noticed is that the binding you are using seems to incorrect. Xiaomi MI Device… seems to be connected using Xiaomi Mi IO Binding. I suggest uinstalling that binding(if you are not using it fir something else). Remove both Xiaomi entries. Add MI Home Bridge using Xiaomi Mi Smart Home Binding. Your Gateway should now be added as a Thing to Xiaomi MI Smart Home Bridge. I hope it helps.

Hi. Unfortunately i couldnt get it to work. The same problem again, the hub doesent apear in Things.

Can you share a screenshot and details of exactly what you have done?

@Tazeem_Naqvi nothing has changed as in my first post. The same status: Xiao Mi bridge - Offline.

I would like to offer 10euro to anyone who can help me out configuring this over TeamViewer!

I don’t need your 10 Euro. I would like to help.

Hi, I have the same problem.
openHAB 2.4.0, synology hardware and software, Xiaomi Mi lumi-gateway-v3, java 8.0.212

auto search found nothing

manually add: Xiaomi Mi Smart Home Bridge - 5 min “initializing” - than “offline”

In phone Mi gateway works OK

I try reinstall binding (I must manually delete thing, in paper still show “removing”) - same result

Problem solved. I opened the Gateway and hardwired TTL to USB, the opened port 9898. After that the hub was discovered and came online.