Xiaomi bulbs stopped accepting brightness information correctly

All my Xiaomi lights stopped accepting brightness information correctly.
I cant set them to anything higher than 97% brightness, if I try the just reset to the previous value.
I have tried turning the power off and on to the light, without success.
Here’s the light I have.
two of these:
and one of these:

Try restarting OH if that does not work delete the devices, uninstall/reinstall the binding and rediscover the devices.

Yes, in 2.5.5-snapshot this has been resolved.
It sends all values until 100%.

Some lights don’t like 0% and 100% and I made a change that avoided sending those. That was included in 2.5.4.

It had some non intuitive side effects like you saw hence I improved it.

If you want to stay on 2.5.4 you can do to following:
Download the json dB file for your device from GitHub put into the conf/misc/miio folder.
Remove the line with the condition in the brightness channel from the file. This will make that brightness is always send regardless of the value…

1 Like

Thank you, that’s really useful to know.
Honestly I just set all the lights to 97% and it works fine for me.

I’m having a similar problem. i recently update openHab to 2.5.8-1. and Xiaomi IO is on version 2.5.8.
since then i cant adjust brightness at all. In my rules i used to send a command with a value between 0 and 100. now when i look at the log it displays values between 0 and 1. but entering a value manually in paperUI,either like 0.5 or 50 doesn’t work either.
the only way to adjust it is with the slider in paperUI. but its a bit buggy, the slider constantly resets itself and goes from 1 to 0 or 0 to 1

hardwareVersion MW300
modelId yeelink.light.color1
vendor Xiaomi
wifiFirmware SD878x-14.76.36.p103-702.1.0-WM

Doesn’t sound at all similar problem.
What are you sending that command to, may we see the definition? What are those logs you are looking at, we can’t see them? When you make those changes in PaperUI what do the logs say then?

What it the type you are using.
It should be a dimmer… as is accepts a percenttype input

I see what happend, before the update of the add-on, the brightness item was defined as “Number” in your examples in the add-on page. I see now it is as “dimmer”. Changed all my brightness-Items to dimmer and now it works again.

1 Like