Yale Conexis L1 Smart Lock + Z-Wave Module 2 (SD-M1100) - Add to database

Once I’ve “approved” the changes, then they will be compiled in to the binding. The you will need to update to the latest snapshot so that it picks up the new database.

I will try and do this tonight.

I tried the updated version of the binding today, but I still get ‘Unknown Device’ - it looks like the changes on SD-L1000-CH are not yet updated?

I apologise if I made a mistake with this one, I think I may have accidentally ‘edited’ (without changing anything) the ‘Yale Smart Door Lock Z-Wave Module’ in the process of creating the Conexis L1! Please do let me know if I’ve made any mistakes, or if you need me to get some info off the device.

@chris, do you think it would be possible to recompile the binding after approving the info in the DB for SD-L1000-CH?

I plan on doing an update tonight, but at the moment, you’ve not requested a review (which is why it wasn’t approved yet :wink: ) and I just checked and probably the reason you didn’t request review is because there are a bunch of errors -:

It looks like simple stuff - just updating the information in red below -:

If you can do that in the next few hours then I’ll get it in the binding tonight…

Hi @chris - sorry about that! I’ve included the additional info, and I’ve requested a review!

Thank you again for your help!

Hi All, Has anyone got this working successfully?

I’m really struggling to get it to work as it does not seem to fully initialize. I have tried to include and exclude multiple times using a triple click on the device. It connects but says “Unknown Device”

If anyone could let me know if they have it working or if they feel it should then that would be great, thanks in advance.

Sorry, but this doesn’t really provide a lot of information. Please describe your problem so that we can try to help.
A few thoughts -:

  • What point is it getting stuck on in the initialisation?
  • Does the secure inclusion work?
  • What do the properties show for the device in HABmin/PaperUI?

Debug logs will also be quite useful if you can provide them.

I feel it should :slight_smile: .

Hi Curtis,

I can confirm I have it working with the same hardware.

I had difficulties at first (documented in this thread) but after it was added to the DB with the updated binding it connected fine. Note that it really did have to be very close the first time - although 1m should be fine.

Do you have other Z-wave devices on your network that are working OK?

Hi Chris, many thanks for your quick response.

Below is as far as I can get which appears to be at the exact same point as @Stevemutch earlier in this topic (8th April)

Where can I find the Debug logs for you? events.log? openhab.log?..

Thanks Curtis,
So, from this, there’s a couple of points to note - first, and most important, is that in the properties zwave_secure is false. This means that the secure inclusion didn’t work, and for a lock, that’s pretty much a killer. That said, the next interesting point is that the type/ID is not known (bank in HABmin, and missing in the PaperUI list). This also indicates that the initialisation failed - now this could be related to the failed secure inclusion, but generally locks allow this level of information to be supplied even in insecure mode, so there may be other comms issues at play…

Docs for logging can be found here.

The crash course is to use the Karaf console command log:set debug org.openhab.binding.zwave. This will enable debug logging. The logging will go into the openhab.log directory, which is in the {userdata}/logs folder (the exact location of this might depend on your OS so check the installation instructions for your install…

OK thanks I’ll enable debug logging.

Once done I guess I just exclude the device and re-include and post the new logs here?

Or do i just leave as is and see what the logs say?

No - do the exclusion and re-include.

To be clear (since this seems to be a common mistake) - you are using HABmin/PaperUI to do the inclusion right? You’re not including via the button on your controller or something like that?

OK will do.

Yes I’m using HABmin. I’m using a Pi.

Wow that does create huge log files. I had no idea how to just send you the bits you wanted to look at. I think I’ve caught the beginning and end of the process.

openhab.xml (422.6 KB)

Yeah it is strange I cannot get it to work. Yes I have about 20 other z-wave devices all working perfectly. Did you have to keep the lock awake somehow or did you just, set the gateway to inclusion, triple click the button on the lock and add it when it pops into the inbox?

If memory serves, after the initial pairing, I opened and closed the lock a few times to ‘wake’ it, so all the details were picked up. I think I also changed the Z-Wave security setting in Habmin to ‘Always’, but I’m not sure if that made a difference.

Hmm, excluded and tried again your way without success.:slightly_frowning_face:

When you say “Always” I guess you mean set Secure inclusion Mode to All Devices?

Below are my settings.

The problem that I see in your log is that when the inclusion happens, there is a lot of other traffic - possibly some other devices are still initialising. This blocks the key exchange which has tight requirements on timing (ie it must complete within 15 seconds of the inclusion).

Probably the binding needs to change the prioritisation at this time to try and avoid this, but for now I would suggest to make sure all devices are initialised and there’s not too much traffic on the network when you start the inclusion of the lock.

That makes sense thanks. When I moved onto the development binding I think a few sensors had not fully initialised.

I have now managed to connect the lock successfully. :grinning:

Not sure what fixed my issue, may have just got lucky but this is what I did:

  1. Moved the Pi to 1ft away
  2. Excluded the lock using HABmin
  3. Deleted the lock using HABmin
  4. Restarted Pi
  5. Clicked inbox in PaperUI, clicked the plus and selected “Z-Wave Binding”
  6. Triple clicked the button on my lock
  7. When I noticed the lock pop up as Node38 I just kept opening and closing the handle
  8. It then finally updated to the correct name
  9. I then added it as a thing

I much appreciate everyone’s feedback and advice. It was nice to know others had it working as it spurred me on to keep trying.

Hi Guys

I’m having the dreaded 3 day battery issue with the Yale Z-wave Module 2 that is widely reported on the SmartThings forum. However some people seem to get just over a month with it now.

I’m curious how long your batteries last? @S13_Mills @Stevemutch

I would rather try and fix the issue and use openHAB rather than pairing it with my SmartThings.

I’m assuming it is not a binding problem and rather some settings or something? @chris


  • Battery level was fine without the module
  • Brand new VARTA Max Tech Alkaline batteries
  • My controller is about 3 metres away from my door through a wall
  • Lock firmware: 1.1.0.
  • Lock Model: 66000002FFFFFF
  • Door is opened and closed about 10 times a day
  • Looses at least 30% battery life per day
  • Overnight it lost 25% when it was not touched all night
  • Controller: default battery wakeup period is an hour
  • Conexis: Polling period = 1 day
  • Conexis: Command Poll Period = 1500

If anyone has any ideas or advice that would be great.