Yale YRD256 Lock in secure mode

I am struggling to figure out what I am missing. I have a fresh openHAB windows install using the 2.5.0.Snapshot from just a few days ago.

I am using Aeotec Gen5 Z-Stick, and have 60+ z-wave devices functioning.

I probably should have started with the lock, but unfortunately I did not, and I’ve read that you should add secure devices first before others.

I am struggling to get the Yale lock loaded in secure mode so that I can lock/unlock the device via openHAB…at least lock.

I’ve read all about the development version of the Zwave binding when Chris was getting the “secure” functionality developed. That was however a few years ago now and I would assume that it is merged within the Snapshot builds.

Can anyone confirm that, or do I have to go with a development build of the binding to get this functionality?

Terry

No, this was merged a long time ago.
As I already told in your other thread: for each inclusion attempt you need to factory reset your lock and inclusion needs to be finished within 15 seconds.
For some secure devices the device must be very close to the controller during inclusion.

If you still have problems please enable debug logging for the next inclusion attempt and post it.

“I” actually don’t have another thread about locks and I’ve read hours of other peoples threads on the matter, I just wanted to ensure that I am using a sufficient version of the software.

I’ve done everything you’ve suggested here to no avail…I think I am fighting with the problem of the assosciation groups…looking in both habmin and PaperUI, there is no Lifeline. Trying to add one anywhere won’t save.

I will definitely try again with debug logging enabled.

Thanks,
Terry

So, you’ve included the lock but it’s not responding when you change the state of an Item linked to the lock_door Channel? Do you see a green check mark or red X in Habmin> Configuration> Things> your lock’s Thing> Attributes> Using security?

1 Like

That is correct, and yes, correct, I have a red X in regards to using security. Lock failed to be included in Secure Mode. I plan to delete all my devices, but fully exclude the door lock, reinstall the ZWave binding to get the one from yesturday because it should have a different update I need in the database for another device, then enable my debug log and try again. I am running openHAB on Windows using Aoetec Gen5, so I’ll even dismount the door lock and place it next to the PC during inclusion, eliminating any concerns about range or timing.

This shouldn’t be necessary.

Exclude and hard reset it.

:+1: I usually have them touching the controller (different lock) and it still sometimes takes a few tries. Also, let your network settle down after starting up OH, before doing the inclusion.

My Yale can normally be included from the opposite end of the house. Unless it’s an old lock it shouldn’t need to be close to the controller as the requirement / recommendation to use low power for secure inclusion was removed a long time ago.

Top advice :+1: .

If there is a lot of other traffic, it will delay the secure inclusion and since the timing requirements are tight (key exchange must complete within 15 seconds of the inclusion into the network) any delay of more than 5 to 10 seconds is likely to prevent secure inclusion from completing.

Okay, I like to share good news…even if this good news make me look like a complete noob.

Possibly I have done this the absolute hardest way possible, or possibly I have come across something that other users will be able to use to assist them…here goes…

I failed including my Yale lock nearly a dozen times…I tried including, excluding multiple times…I ensured things were done with zero other z-wave traffic. I tried the manual way removing the Z-Stick from the PC and bringing it to the door lock for inclusion…I tried removing the door lock and bringing it next to the Z-Stick for inclusion. Each and every time things would fail…Inclusion was successful, but it would fail on a “Secure” inclusion, and zero feedback, not even battery life was readable.

During this mess, I started not being able to remove a device from PaperUI. I exclude the lock from the Z-Stick, but it kept showing up in the Inbox over and over. When I exclude and include again, I would expect it to come into the Inbox with a new node number, but it kept coming in as the same. So, I figured there was a problem with the exclude activity. It’s weird though because this only started happening on the 10 time or so. I shut down openHAB and restarted several times, and it kept coming up again.

So then I went to Aoetec’s website. There I found some developer tools (needed to register as a developer). One specifically is called Z-WAVE PC Controller 5.38. It is a tool that shows all the details of the network, the devices and many of the things that HABmin will show, but much more. In there I did not see any of the former lock devices that I had included and excluded, so it confirmed that my openHAB was clearly confused with my attempts to include and excluded repeatedly, so I had an idea to try and include this lock within the Aeotec software to see if I could include it in secure mode. So I did, and right away, it did indeed get included in secure mode, so I was very happy. I was not sure what would happen when I fired back up openHAB…I wasn’t sure if the binding would load this item into the inbox like normal and if so, would it be in secure mode. So I tried that, and sure enough it was in the inbox, but after it was all said and done, it was still not in secure mode. So, it led me to believe the Network keys were messed up. So I went back into the Aeotec tool and found the Network settings screen and copied this value…went back to openHAB and pasted this value into the Z-Stick Things network setup. I restarted openHAB to be sure and then I went into the lock thing, went to advanced properties and clicked on Re-initialize device. AND IT WORKS! I did not need to exclude and include again.

So, possibly the moral of my long story is that my Network Key was wrong/corrupt/invalid the entire time? I would have thought you could have any network key you wanted, but I just left the default value in that field…I just assumed that the default value would work.

I donno, but it was fun learning, but frustrating to say the least…at least I can move on to the next challenge.

Sorry for the long story and thank you to all of you who chimed in to help.

And, nope, I wouldn’t be upset if you called me crazy!

Terry

1 Like

That will never work for secure inclusion. There must be a gateway to manage the security.

Excluding a device does not remove the Thing… you have to manually delete the Thing.

This is actually from Silabs… https://www.silabs.com/products/development-tools/software/z-wave.

Glad you got it working! I haven’t tried a secure inclusion in a while, but my garage doors have both lost their keys as they do about every 6 months, so I will be soon.

Yes, certainly…when I say exclude, I actually mean delete the thing from openHAB as well as exclude on the controller.